Please help me understand this error message


I just started learning PowerShell using the book “Learn Windows PowerShell in a Month of Lunches.” I’m in chapter 3, “Using the Help System.” I ran the update-help command and I got the following response:

PS C:\WINDOWS\system32> update-help
update-help : Failed to update Help for the module(s) 'ConfigDefender, PSReadline, WindowsUpdateProvider' with UI culture(s) {en-US} : Unable to retrieve 
the HelpInfo XML file for UI culture en-US. Make sure the HelpInfoUri property in the module manifest is valid or check your network connection and then 
try the command again.
At line:1 char:1
+ update-help
+ ~~~~~~~~~~~
    + CategoryInfo          : ResourceUnavailable: (:) [Update-Help], Exception
    + FullyQualifiedErrorId : UnableToRetrieveHelpInfoXml,Microsoft.PowerShell.Commands.UpdateHelpCommand

After digging a bit into the update-help command online, I ran
Get-Module -ListAvailable | Where-Object -Property HelpInfoUri
and got an extensive list of modules that I won’t reproduce here (way too long).

The three modules that PowerShell said it could not update were in this long list of updateable modules. Therefore, I reran update-help again, and I got the same response for the same three modules.

Can you please help me understand what’s happening here? Am I doing something wrong? Is there a problem with my PowerShell setup? What do I need to know here that I am overlooking?

Thanks for your help!

Did you check for a module manifest (.PSD1) for those 3 modules per the error message and validate the HelpInfoUri property ?

1 Like

Thank you, tonyd, for that helpful insight.

As I said, I am entirely new to PowerShell and was not aware that each module had its own module manifest. After checking, I found that each module had a module manifest, but the HelpInfoUri links in the manifests returned 404 in two module manifests and an XML error in one of them.

<Message>The specified blob does not exist. RequestId:ff37db62-a01e-0009-325b-e68f83000000 Time:2021-12-01T02:28:14.6295712Z</Message>

Being completely new to this scripting language, I’m unsure what to do other than ignore the error and move on. Do you have any suggestions on what I should do?

Thank you, again, for your help.

You will have to ask yourself if you urgently need the help for these particular modules updated. If the answer is “no” you may move on focussing on something meaningful to you. :wink:

1 Like

Thank you, Olaf.

I am going to move forward with the lessons and not worry about it. :slightly_smiling_face:

1 Like