Update-Help Fails for module 'WindowsUpdateProvider

Hi!

I’m still relatively new to the joys of PowerShell, so forgive me if this is something obvious. Lately, updating help repeatedly fails but only for one module - WindowsUpdateProvider. This is the exact error message I get:

[pre]Update-Help : Failed to update Help for the module(s) ‘WindowsUpdateProvider’ with UI culture(s)
{en-US} : Unable to retrieve the HelpInfo XML file for UI culture en-US. Make sure the HelpInfoUri
property in the module manifest is valid or check your network connection and then try the command
again.
At line:1 char:1

  • Update-Help
  • CategoryInfo : ResourceUnavailable: (:slight_smile: [Update-Help], Exception
  • FullyQualifiedErrorId : UnableToRetrieveHelpInfoXml,Microsoft.PowerShell.Commands.UpdateHelpComm
    and[/pre]

I found this one article online that references it may just be that it’s not being developed?

I’m sure I can safely ignore, just curious if anyone was aware of a work-around or knew something more about it than me…

you can refer to below post, it’s about the same.

https://powershell.org/forums/topic/update-help-failure/

I just got the exact same message as I tried to run PS ISE 5.1 on a brand-new laptop (Win1o).

Mr KVprasoon’s referenced solution works. As stated in the answer, I typed

update-help -force -Ea 0 -Ev ErrMsgDetail

and it worked without any error messages. For what it’s worth, I ran “Update-help” in Powershell Core 6.1 and did not get any such error message.