The Address in the Banner is Incorrect

On the main site, the banner directs users to powershell.org/forums but this goes to a 2013 announcement about a previous upgrade. I suspect most users are finding the forums via the menu, but it’s probably worth updating the banner to the correct address.

Edit: it redirects correctly as long as there’s no trailing /

Works fine for me. Takes me directly to forums.powershell.org

When the link in the post worked, I checked again. It goes to the post if you put a trailing /

Thanks for letting us know @matt-bloomfield . We have fixed this issue now. powershell.org/forums now redirects to here.

Hi @psjamesp

I’m still seeing the same problem if a trailing / is used.
powershell.org/forums redirects correctly
powershell.org/forums/ goes to an announcement from 2013.

The first result on Google for powershell forums is the address with a trailing / which is why I think it’s important that both are redirected.

1 Like

Interesting. It may be a cloudflair setting. Let me look into it

Thank you,
James Petty
CEO
The DevOps Collective INC.

I did a quick test of some default page names and I think you have a index.php file in the folder that displays or redirects to Forums Migration Schedule – PowerShell.org

I have finally figured out what the issue is.
if you don’t put the trailing backslash (/) then the website tries to find the article with the same title.

For instance powershell.org/website will pull up Website & Forum Updates – PowerShell.org

@matt-bloomfield finally found it. Wordpress has a new feature called predictive search. Found the setting and disabled it. It was trying to match the url with a post as opposed to showing a 404 error

@psjamesp it still doesn’t redirect for me when the trailing / is used. The behaviour is different, since your change: I no longer see the post about the forum updates but I do get the custom 404 page (network trace in the browser confirms the server is returning a 404 error).

I have tested with a different ISP and a different device/browser to rule out local caching problem.

@matt-bloomfield try now :smiley:

Site is looking good. When you get the forums, there is no breadcrumb or way back (link) to the main page (that I can see). my .02

@psjamesp yes, it’s working now :+1: