@ key set permanently (only in powershell) without me pressing it

Hello, my laptop keyboard is not the newest anymore so there must be a hardware malfunction and some signal is sent that results in @ getting permanently sent in Powershell, but only in admin mode. It does not happen in the browser address bar, notepad, cmd or wherever else. I disabled the q key already completely, but it still gets sent, so it has to be another combination that causes it. There are minor issues on other occasions too, like when I right-click powershell (or anything else) from the start menu, the context menu opens very briefly only for a second, then closes and when I open applications, they usually open in the background (instead of on top of everything else) and I have to minimize everything in the foreground to get there, so whatever causes this also happens outside of powershell, but with really minor consequences only.
Anybody has an idea what is the combination of keys that causes this. I tried several key identifier programs that give out the key you are pressing, but no success really. One got me a result, but when I disabled it, the issue was not solved either. I will try to add screenshots:

the screenshot of the issue:

Hi, welcome to the forum :wave:

We’ve had a previous post about this and it appears to be related to particular models of keyboard. Plug in an external keyboard if you have one and use that instead.

You can also use Remove-Module PSReadLine to remove the affected module if you don’t have an spare keyboard. This will remove some functionality like syntax highlighting and intellisense suggestions.

Previous Post

PowerShell Issues on Github

Hello Matt, thank you for your response. Right now, I disabled the circumflex key left to the 1 on my keyboard and I did not get the @@@s anymore since I did.

What is the remove module psreadline? I just copy paste it into powershell?

Yeah. The links @matt-bloomfield have additional salient details as well.

Okay forget about what I wrote about disabling the circumflex and function key on keyboard, it sadly does not solve the issue and was probably just coincidence that it did not happen again afterwards yesterday.

but the Remove-Module PSReadLine is working fine and solves it in Powershell, at least until restart

Would still be appreciated if anybody has an idea about the exact key combination that is pressed automatically by my keyboard that causes it or maybe can identify the (0h) in my first screenshot, so I can disable it for Windows entirely and not just in Powershell.

for example with the background opening, it also happens that I open start menu, click on something there and the start menu stays open, which generally should not happen and the application opens underneath the start menu

for me it is a Lenovo laptop keyboard I am having this issue with

You can add the command to your profile so that the module is removed every time you start PowerShell.

Regarding the other problems, it sounds like it might also be keyboard/keyboard driver related. If the laptop is too old to receive updates that might fix the problem then, as previously advised, plugging in an external keyboard should be a quick and easy fix.

1 Like