'@' symbol being thrown into type written text in PowerShell

When typing into PowerShell the @ Symbol gets thrown into the text.

It doesn’t happen with any other program.

What kind of testing have you done? Tried several computers? At first glance I’d initially think a keyboard issue, as the following line is fine.

1 Like

Hi @krzydoug,

The second line is correct because I pressed the up arrow and backspaced on the offending characters.

I will try another keyboard but I am not sure it is the culprit. I use it within VMs (unix / windows) and command windows without any issues whatsoever.

You say you use it within VMs with no detail how you’re interfacing. You’re going to need to provide more detail if we are going to have any chance at helping you. One would typically assume you’re using a shell directly on your local computer unless otherwise stated.

To clarify:

  • I generally use PS nativly on the host Windows machine. The issue I have is on this platform.
  • The issue only manifests itself on the hosts. When I use PS on VMs (using the same keyboard) I don’t get the @ symbol periodically thrown into the mix.

Over the weekend I’ll try replacing the keyboard and will report back

Natively accessing the host VMs? I’m not sure what you mean by that. Why can’t you just say how you’re interfacing with it? Are you using VMware console? Hyper v? RDP? Maybe powershell remoting?

Thank you for your interest. IMO my opening comment was complete.

PS on my computer introduces the @ symbol when I’m typing. This does not happen in any other program or the command prompt. I tried PS in a VM and it does not introduce the @ character as I am typing.

Hope this clarifies.

When requesting troubleshooting help, it is very, very helpful to be as clear and detailed as possible. If I as for help, and the person I am asking that help from is not clear on what I am saying, describing etc, it does not matter how clear I think I am, clearly, I wasn’t, and it is up to me to try and be clearer.

If English isn’t a first language, we call all be patient with each other, but I do agree your posts do not yet create the clearest picture of what is going on.

Lets start with some hopefully clarifying questions.

When you run into this issue, what type of computer are you logged into? Windows 10? Windows 11? Windows Server and if so, which version? Or are you using Linux or maybe a MAC?

When did the issue start? Just the day it happened, and then you posted for help?
What were you doing just before it happened?

Does the @ symbol appear before anything you type in the console? Or just the exampled cmdlet?

What have you done to troubleshoot?
have you simply closed and reopened the console? what is the result?
what about a reboot if possible? if so, what was the result?

you mention testing on vms. more info about the vms and how they were accessed might be helpful. Is the vm VMWare based running on the same host you are running into the @ symbol issue? Is it remote to another host? how are you accessing the guest vms? console (the vm equivalent to walking up to a keyboard and monitor physically)? by a remote method such as powershell or remote desktop (RDP) etc.

Details can be helpful.

No sadly it does not clarify. I’ve used powershell on thousands of computers through dozens of interfaces and I’ve never seen anything like what you show. I can say with great confidence the issue you’re experiencing has very little, if any, chance of being caused by powershell. Good luck to you.

The culprit is the Microsoft Wireless Comfort Keyboard 1.0A. I will post this in a Microsoft Hardware forum to see whether I am unique.

The only program that inserts the @ symbol (the ones I own) is PowerShell. If has happened with multiple versions.

Office programs, Command windows, browsers all work as expected.

I have a Logitech keyboard plugged into my USB and use that for PowerShell.

@krzydoug you said that you’ve worked on thousands of computers. Have you ever interfaced using this keyboard in PS?

Video demoing the problem: Microsoft Wireless Comfort Keyboard 1.0a and Powershell - YouTube

I can’t say that I have. I’d be curious the specific driver used with this issue. Have you tried changing drivers? Did you confirm this keyboard does the same on multiple computers? Sounds weird for sure.

No driver installed.

The only two comments I can make are:

  • It is OLD. A Google search from 2006 makes reference to it.
  • It originally came with a mouse but that died.

What boggles my mind is that no other tool (and I work from home in a job that involves a lot of typing) manifests this problem.

This discussion led to a semi-solution (in an inefficient round about way); if I want to use PS for any length of time I will fish out the Logitech from behind the monitor otherwise I need to look at the screen and be prepared to press a few backspaces.

Same problem reported here and they also identified it as a hardware problem.

It appears to be a problem interacting with PSReadLine. Does Remove-Module PSReadLine temporarily resolve the problem for you?

I’ve been pounding on the keyboard and no @ symbol :+1:

Problem resolved.

What are the implications of removing PSReadLine

The most noticable will be the loss of syntax highlighting, Intellisense suggestions, and history.

I mean you should’ve started at “I have this 16 year old keyboard” lol. Glad you figured out what the keyboard messes up with.

Oh and by the way, all devices use drivers.

I am aware that all device uses driver. My point is that this device does not have a specific driver.

The fact still remains that all other applications work as expected.

Yesterday after reading your 16 year comment I fished out a keyboard from the 1990s (using a 6 pin DIN) and using adapters plugged into another computer. PS worked without introducing any symbols.

The issue is not age but the keyboard.

Which is precisely what I said in my original reply. :innocent: Basic troubleshooting would’ve revealed this instantly. This is why I asked what troubleshooting you did to indicate this issue was with powershell vs your keyboard. Again, glad it’s resolved. Take care.

1 Like