Get-Help - Showwindow

Just a quick question I can’t seem to find anywhere, but after installing a few newer modules and update-help, now when i use get-help -showwindow with ANY object/cmdlet I no longer get parameters in the window, I do still get that info, if i do -detailed or -full within Powershell. So the help file contains the information just no longer transfers it to the showwindow command. Is there a way to reset things or fix this issue? And yes I have confirmed I do not have parameters unchecked within the showwindow box.

Also I am updated to Powershell 5.0

Thanks

Hi Johnathan,

Any cmdlet? even:

 get-help new-item -ShowWindow

produces an empty help screen?

Or is it with, for example, Exchange related cmdlets?

Albert

Well no, thats the thing, its not blank, it shows all other criteria, just not Parameters, which honestly is the main reason I discovered and like to use -showwindow instead of viewing from within the powershell window itself. Its very strange. Its only on my machine itself, if I do the exact same thing on another machine I have 5.0 on, it works as expected. Is there anywhere to clear the help and then just update it back? Or where would I even start with troubleshooting why it ONLY leaves out parameters when using -showwindow?

… checked it on my clients:

  • W7 x64 Enterprise / PSVersion 5.0 -> same behaviour as you described it
  • W10 x64 Enterprise / PSVersion 5.0 -> works as expected including parameters

So it seems to bee a bug.

Yeah, I’m using W10 x64 enterprise/PSVersion 5.0. Oddly it worked before the upgrade to 5.0 so that makes sense its a bug. But seems to be a random one if it works on 10 for you…