get-help about* dosn't show anything

Hi everyone,

im new to Powershell and saw the greate mva courses of Jason Helmik and Jeffrey Snower.
Now i tried some stuff in powershell, but it seems that the

does not work probably.
when i type
get-help about*
it shows me nothing. Did i miss something?

Im on a windows7 system running powershell 3.0.

kind regrards


try this…

help about_* # with the underscore

Were you running PowerShell as an administrator when you ran Update-Help? As a test, try accessing one of the files directly, like Get-Help about_Operators , and see if that works.

Thanks for your help. the get-help about_* didn’t work for me.

I ran powershell unter administrator (see screenshot). The direct access didn’t work either.

I followed this artikel just to get sure I have a proper installation.

What happens when you run Update-Help while running PowerShell as an administrator? Do you get any errors?

On a side note, a did a quick web search on “German PowerShell help”, and you may be running into some problems there if some or all of the help content hasn’t been translated yet. One suggested workaround was to attempt to load the English language help files like this:

Update-Help -UICulture en-US

No i don’t get errors. That’s what’s confusing me a bit, it seems that it does not update all modules.

When I’am at home at my win8.1 maschine the update help command works just fine. It updates more modules than my pc at work does.

thanks, that worked…

damn lokalisation… i dont want that german stuff.

Update-Help -UICulture en-US

so can i set that as a default??

Only by changing your regional / language settings. The command appears to default to using [System.Threading.Thread]::CurrentThread.CurrentUICulture and [System.Threading.Thread]::CurrentThread.CurrentUICulture.Parent, if you haven’t specified anything with the -UICulture parameter.

Good to know. Thanks for your help. I appreciate it.