Who pinched the help for Convert-String?

I was looking for commands for strings (Get_Command string) and noticed Convert-String. I ran Get-Help Convert-String -Detailed and got only a little information but the Remarks section included “Get-Help cannot find the Help files for this cmdlet on this computer. It is displaying only partial help.”. It also suggested running Update-Help, which I had already done, but ran it again but that did not resolve the problem. Another suggestion was to use the -online option but this only took me to the TechNet Library.

So, whoever it is that has ‘borrowed’ the help for this command, please put it back or at least tell me how to find it.

PS the Microsoft.PowerShell.Utility module was loaded.


Hey mate,

Some of the newer cmdlets that were introduced in version 5.0 (such as convert-string)don’t have extensive built-in help yet. I’m sure the PowerShell team are working on updating the help for all of the newer cmdlets. Its the same story with a lot of the DSC cmdlets. You’re best bet is to check online as you mentioned.

I think as a good idea Microsoft should offer some way to upload examples for cmdlet usage so that others can use some sort of -FromCommunity switch parameter on get-help that would essentially show you how others have used the cmdlet. Just my 2cents.

Thanks for the reply Flynn.

As a newbie on PowerShell I didn’t realise that Convert-string was a new commandlet but it does explain the lack of good help.

I do think that your -FromCommunity suggestion is a good idea tho.

Have you actually gotten Convert-String to work for you? I tested it using the example provided in the WMF 5.0 April(I think) preview and it did not work. I tried using a different, but similar pattern and I got no error messages and no output.


Convert-String is pretty useless. I’m surprised they included it in this release in it’s current state. I could find almost nothing it worked for reliably, and no useful scenario I could think of worked.

I traded some emails with on of the engineers that worked on it, and he acknowledged that it can’t do much. Sometimes that error you get includes an email address for the development team (which is NOT the PowerShell team). If you send them what you were trying to do, they can add it to their list of things we hope it will do in the next release.