Trying to update module Az.Compute

All, I am trying to update a module Az.Compute to the latest which has more parameters available. The latest available version is 9.4.0. however, when I run the following on PS Console

Find-Module -Name Az.Compute -AllVersions

I receive 5.4.0 as the latest from the gallery while 9.4.0 is the latest on Microsoft.
and, when I run the Invoke-AzVMRunCommand from ISE with ScriptString(which is not available in 5.4.0) parameter, it is running fine with no issues.

my questions are:
#01. Why the console latest version from gallery is different than what’s listed on Microsoft learn.
#02. How come it’s working in ISE but not in Powershell Console.

Can some one provide some insight into this please if I am missing something here.

Thank you!


Find-Module -Name Az


Version Name Repository Description
------- ---- ---------- -----------
9.4.0   Az   PSGallery  Microsoft Azure PowerShell - Cmdlets to manage resources in Azure. This module is compatible with PowerShell and Windows Pow...


1 Like

Thank you for your response @Olaf. I am updating my Az module now.