SCCM Issue with Set-CMDeploymentType

I previously ran this command to change all my SCCM 2012 application to allow fallback for source locations

 Set-CMDeploymentType -ApplicationName $application.LocalizedDisplayName -DeploymentTypeName $DeploymentType.LocalizedDisplayName -AllowClientsToUseFallbackSourceLocationForContent $true -OnSlowNetworkMode Download 

After running this command I found that all my applications changed the logon requirement from “Whether or not a user is logged on” to “Only when a user is logged on”.
I need to change all my applications to “Whether or not a user is logged on”.

I tried using this command, but the expected result is not happening. The logon requirement for the application is not changing.

 Set-CMDeploymentType -ApplicationName $application.LocalizedDisplayName -DeploymentTypeName $DeploymentType.LocalizedDisplayName -MsiOrScriptInstaller -LogonRequirementType WhereOrNotUserLoggedOn 

Am I using this command incorrectly? I am not getting any errors when the command is run, and when using the verbose option all I see is:

VERBOSE: Performing operation "Set" on Target "DeploymentType: ".

Thanks for your help!

It may be a bug with Set-CMDeploymentType. Take a look at this article to see if it resolves the issue:

Also, since this is a MIcrosoft owned cmd-let, you might have better luck on a SCCM 2012 forum to validate if it is a bug and getting it corrected if validated.