Powershell display resolution problem.

I am running into a strange screen resolution problem using Powershell. My OS is Win10Pro with all latest updates.
I have only 1 image in docker, that is Ubuntu. I tried to run this image (I have tried running Powershell in administrator mode. Same issue. Have removed Powershell, rebooted, enabled Powershell again, same issue. My screen resolution display is at original default setting.)

The command I use was: “docker run-it ubuntu /bin/bash”
Then hit enter
The cursor moved to the next line. The line is blank.

I opened another Powershell. I saw the Ubuntu container was running.
I stopped the container. When container was stopped, at the original Powershell (the one where cursor shown a blank line) returned this:

“]0;root@4de9d9044928: /root@4de9d9044928:/# exit”

So, “root@4de9d9044928:/#” has been displayed on this Powershell all along. But it was displayed beyond the left edge of the screen. This is a screen resolution issue in my Powershell.

To do a control test, I used dos command prompt.
I issued the same command to run the Ubuntu image and hit return.
Dos returned: “root@f371ceca0b1a:/#”
No issue there.

Can someone please tell me what I should do to make this Powershell display its output properly?
The computer is less than 1 year old. So, it is not likely to have mess up registry problems.

Thanks in advance.


The PowerShell window is just set to have a large width. Modify it from the console window’s properties page.