Partial Configuration Bug - 8 config limit

I’ve been trying to configure node’s LCM with 9 partial configurations, however when you apply the LCM config to the node the following error appears.

The WS-Management service cannot process the request. The WMI service or the
WMI provider returned an unknown error: HRESULT 0x80041033
+ CategoryInfo : ResourceUnavailable: (root/Microsoft/…guration
Manager:String) [], CimException
+ FullyQualifiedErrorId : HRESULT 0x80041033
+ PSComputerName : TestNode01

If you reduce the partial configurations to 8 the error does not appear. Can someone else confirm they are seeing the same issue? I can’t find any documentation to say there is a 8 partial configuration limit.

PullServer/Node Specs

  • Powershell v5.0 (April preview)
  • Windows 2012 R2 (Update) - Full Patched

I’ve attached proof of concept code http://www.megafileupload.com/4T0g/PartConfigBug.zip

I’d consider filing that in Connect, so the product team can see it.

Thanks for confirming Don! It’s on Connect now.

https://connect.microsoft.com/PowerShell/feedback/details/1624273/dsc-partial-configuration-bug-8-config-limit

I would be most appreciative if you and anyone else could vote it up.

I have run into the same bug in WMF5.0. Have upvoted the bug.

Have you had any luck finding a workaround?

Hi Lerun, I believe this was fixed in WMF 5.0 RTM. I haven’t had any issues since using it. What version of 5.0 are you using?

Hi Zuldan and thanks for taking the time to answer me.

I’m running RTM of WMF5.0 (KB3134758), with PSversion: 5.0.10586.117. on Windows Server 2012 R2.

The reason I think it is the same bug, is that if I remove some of the modules before the offending one, DSC will run past and continue on. If I add the other modules back in, DSC will stop running after trying to import module nr 10.

I’m actually just trying to test installing WAP using the xAzurePack code found on github. And only doing this:

Configuration WindowsAzurePack
{
    Import-DscResource -ModuleName PSDesiredStateConfiguration
    Import-DscResource -ModuleName xSQLServer
    Import-DscResource -ModuleName xCredSSP
    Import-DscResource -ModuleName xWebAdministration
    Import-DscResource -ModuleName xCertificate
    Import-DscResource -ModuleName xAzurePack

Seems like wmiprvse.exe crashes at the same time on the host I’m pushing the configuration too.
Not sure I’m doing anything wrong, or if the config authoring has changed with WMF 5.0 to circumvent this problem.

Seems to work for me with the configuration script below and newer build. Could you share your the configuration script after removing some PI information. Just want to understand the bug.

 
[DSCLocalconfigurationmanager()]
Configuration test
{
    Settings {
    RefreshMode = 'Push'
    }
    foreach ($i in (1..10))
    {
    PartialConfiguration "p$i"{
    }
    }
}
test
slcm .\test 

In the process of creating an better example I got it to import all the modules without error. This was the same code I was struggling with, though I removed most of the logic only leaving the code that installed the WAP admin portal. With this reduced payload DSC ran past the error and loaded all 11 modules without problem.

Though if I run the full configuration, it will terminate because of an error trying to load the 10th module. A bit of a head-scratcher.

The working code has about 800 lines, while the failing has about 1800.

Potential limit of the default WinRM listener that you might want to increase ?

https://msdn.microsoft.com/en-us/library/aa384372(v=vs.85).aspx

Seems the cutoff is around 1500 lines.

Arie: I am running with higher than default settings when it comes to all WinRM.
MaxMemoryPerShellMB = 2048
So I doubt that is the cause of it.
But thanks for the suggestion.

Seems I spoke too soon, this limit is controlled by MaxEnvelopeSizekb setting in WinRM. Increasing this from the default made me able to use larger configurations. The default is 500, and that is to little. Setting it to 2048 solved all my problems.

Hope this will help somebody else in the future.

Glad to see it was solved and thanks for retuning with the solution.

Hi folks,

I need to borrow this thread.
I’m having similar problems when I am trying to push a LCM config to client server with 7 Partial Configurations. If I remove one partial, everything works fine.
I have tried to change MaxEnvelopeSizekb to 2048 and higher on both DSC-Pull Server and client server. Still the same problem. Both servers runs on Win2012R2.
The error I get is:
The WS-Management service cannot process the request. The WMI service or the WMI provider returned an unknown error:
HRESULT 0x80041033

Does anyone know if there is a hotfix or something that fixes this problem or is there more settings in wsman that can be changed?