MVA DSC Module 2, Day 1 Set-DSCLocalConfigurationManager failing?

I’m new to DSC and am following along through the Snover/Helmick examples.

My DSC authoring platform is a Windows 10 desktop and am testing to a single Windows Server 2012 R2 box with WMF 4 installed.

I attempt to run: Set-DSCLocalConfigurationManager -ComputerName $ComputerName -Path c:\Scripts\DSC\LCM –Verbose

but get error:

The WinRM client cannot process the request. The object contains an unrecognized argument: “Force”. Verify that the spelling of the argument name
is correct.
+ CategoryInfo : MetadataError: (root/Microsoft/…gurationManager:String) [], CimException
+ FullyQualifiedErrorId : HRESULT 0x803381e1

I’ve done the following to troubleshoot:

~ re-run Enable-PSRemoting on both boxes
~ Set a Public ethernet interface to Private

…but still get error.

Need to see the LCM Script that created the MOF you’re trying to push to the node

Hi Arie

[test.meta.mof]

/*
@TargetNode=‘test.mydomain.local’
@GeneratedBy=myUserID
@GenerationDate=05/05/2016 14:57:30
@GenerationHost=Windows10Client
*/

instance of MSFT_DSCMetaConfiguration as $MSFT_DSCMetaConfiguration1ref
{
AllowModuleOverwrite = True;
RefreshMode = “Push”;
ConfigurationMode = “ApplyAndAutoCorrect”;

};

instance of OMI_ConfigurationDocument
{
Version=“2.0.0”;
MinimumCompatibleVersion = “1.0.0”;
CompatibleVersionAdditionalProperties= { “MSFT_DSCMetaConfiguration:StatusRetentionTimeInDays” };
Author=“myUserID”;
GenerationDate=“05/05/2016 14:57:30”;
GenerationHost=“Windows10Client”;
Name=“LCMPUSH”;
};

also when I run:

Start-DscConfiguration -Path C:\Scripts\DSC\Config -ComputerName test.mydomain.local -Credential Get-Credential -Verbose -Wait

I get this error:

VERBOSE: Perform operation ‘Invoke CimMethod’ with following parameters, ‘‘methodName’ = SendConfigurationApply,‘className’ = MSFT_DSCLocalConfigurationManager,‘namespaceName’ =
root/Microsoft/Windows/DesiredStateConfiguration’.
VERBOSE: An LCM method call arrived from computer Windows10Client with user sid S-XXXX-XXXX-XXX_blah-blah.
VERBOSE: [test.mydomain.local]: LCM: [ Start Set ]
The WS-Management service cannot process the request. The WMI service or the WMI provider returned an unknown error: HRESULT 0x800706be
+ CategoryInfo : NotSpecified: (root/Microsoft/…gurationManager:String) [], CimException
+ FullyQualifiedErrorId : HRESULT 0x800706be
+ PSComputerName : test.mydomain.local

VERBOSE: Operation ‘Invoke CimMethod’ complete.
VERBOSE: Time taken for configuration job to complete is 11.254 seconds

Hey Jeff – everything we did was on WMF 5, please try and update your server. You will run into several things that may not work correctly if using v4. Let me know if that helps.

As Jason said, even if you were insisting on doing things on WMF 4, dont use Windows 10 for authoring as you’re creating a WMF 5 based mof files and handing them to a server with WMF 4

Thanks guys…Will advise post WMF 5 update

I’ve tried to update this server 2012 R2 to WMF 5 using these bits:

W2K12-KB3134759-x64.msu

but I get an error: The update is not applicable to your computer

again my current PS/WMF version:

$PSVersionTable.PSVersion

Major Minor Build Revision


4 0 -1 -1

Hey Jeff! I think your using the update file for 2012, not 2012R2 – try this one. Win8.1AndW2K12R2-KB3134758-x64.msu

Exactly right Jason, thanks. Installing now for my tests per above

Awesome it works now, thanks Jason

 VERBOSE: Set-DscLocalConfigurationManager finished in 1.431 seconds