Not able to change powershell's console properties


Been searching high and low for an answer to this but I’m not any closer to a solution…

The problem is that whatever i do with the powershell console, it will not “stick”. I have tried to open the .exe directly with a domain administrator accont, and after setting my properties; pin the running powershell to my task bar. Have tried to right-click the powershell icon on my taskbar and change the properties from there as well…

Every time i close powershell and start it up again, it reverts back to the hopeless configuration…

My setup:
Windows 8.1
My logged in domain user is not a local admin, i use a domain admin account to run powershell.

EDIT: It looks like every property sticks, except the font type Lucida Console! If i try to set Lucida Console, and whatever font size, it will use Raster Fonts the next time i launch powershell. If i set Consolas, it sticks…

This is a problem with the Console, not specifically with PowerShell.exe. (You can reproduce the same behavior with cmd.exe, for example.) I don’t know of a fix, other than to use Consolas instead of Lucida Console.

You could try to set the console font directly in the registry, could you try running the following line and let us know what font PowerShell starts with if you set it like this:

Set-ItemProperty -Path HKCU:\Console\%SystemRoot%_System32_WindowsPowerShell_v1.0_powershell.exe -Name FaceName -Value 'Lucida Console'

Start PowerShell by running:


I tested a little bit, and found that Lucida Console works if you put quotation marks around that FaceName string in the registry. However, I’m not sure yet how to modify a particular shortcut to accomplish the same thing (since settings in a shortcut override those registry defaults, if present.)