Node with large configurations fails to send status report to the Report Server

Has anybody run into this issue in WMF 5.0?

Testing out WMF 5.0 and when I tried one of our existing configurations, which has a good amount of resources in it, the following error is logged in the event log after each consistency check:

Job {%JobID%} :
Http Client {%AgentID%} failed for WebReportManager for configuration The attempt to send status report to the server https://johntestx02/PSDSCPullServer.svc/Nodes(AgentId={%AgentID%}’)/SendReport returned unexpected response code RequestEntityTooLarge…

I assume this is because of the amount of resources the node is trying to report on back to the report server. Has anyone else run into this? Can the Report Server configuration be adjusted to accept lager amounts of data?

I created a User Voice post for this issue:

Correct assumption, and User Voice would be the Right Thing To Do.


This is actually a limitation in services underlying the DSC pull service. We hope to be able to improve the experience in the future but in the meantime you should be able to work around it by changing the underlying systems directly. The following thread from StackOverflow discusses the issue and the solution:


Thanks for the tip Mark. I made the recommended change to the web.config file for the pull server website. The errors on the node went away. However, if I query the DSC report server, the node is not fully reporting everything back for it’s consistency checks. Here is an example of what we are getting now. A few of the fields are blank and the StatusData field is missing a lot of data. Also, the EndTime is not right:

JobId : 4c5ebc82-608f-11e6-80fb-005056964bac
OperationType : Consistency
RefreshMode :
Status :
ReportFormatVersion : 2.0
ConfigurationVersion :
StartTime : 08/12/2016 09:18:46
EndTime : 12/30/1899 00:00:00
RebootRequested : False
Errors : {}
StatusData : {{“IPV4Addresses”:[“xxxxxxxxxx”,“xxxxxxxxxx”],“CurrentChecksum”:“9D81AB55F3446614CD89562F792F004C6B45AFAF44496DFB21F9E754DC6AFC89”,“MACAddresses”:[“xxxxxxxxxx”],“Type”:“Consistency”,“HostName”:“xxxxxxxxxx
AdditionalData : {}

If I expand StatusData, it looks like this. It is missing ResourcesInDesiredState.

StartDate : 2016-08-12T09:35:06.8550000-04:00
IPV6Addresses : {xxxxxxxxxx, ::2000:0:0:0, ::1, ::2000:0:0:0}
DurationInSeconds : 8
JobID : {946F7E79-6091-11E6-80FB-005056964BAC}
CurrentChecksum : 9D81AB55F3446614CD89562F792F004C6B45AFAF44496DFB21F9E754DC6AFC89
MetaData : Author: xxxxxxxxxx; Name: PullClientConfigID; Version: 2.0.0; GenerationDate: 08/12/2016 09:35:02; GenerationHost: xxxxxxxxxx;
Status : Success
IPV4Addresses : {xxxxxxxxxx, xxxxxxxxxx}
LCMVersion : 2.0
NumberOfResources : 0
Type : LocalConfigurationManager
HostName : xxxxxxxxxx
RebootRequested : False
MACAddresses : {xxxxxxxxxx}
MetaConfiguration : @{AgentId=xxxxxxxxxx; ConfigurationDownloadManagers=System.Object[]; ActionAfterReboot=ContinueConfiguration; LCMCompatibleVersions=System.Object[]; LCMState=Idle; ResourceModuleManagers=System.Object[];
ReportManagers=System.Object[]; StatusRetentionTimeInDays=10; LCMVersion=2.0; ConfigurationMode=ApplyAndAutoCorrect; RefreshFrequencyMins=30; RebootNodeIfNeeded=False; RefreshMode=Pull; DebugMode=System.Object[]; LCMStateDetail=;
AllowModuleOverwrite=False; ConfigurationModeFrequencyMins=30}
Locale : en-US
Mode : Pull

If I switch back to a smaller configuration, the node reports fine and all the information is there. So there must be something else that is blocking the data. Any thoughts?

Sorry to drum up a year-old post, but did you ever find a resolution to this? I’ve tried the web.config changes and am still having these same issues

Same here, modifying the web.config as suggested did not help as well. Any other solution?

Adding this binding definitions seems to work:

for some reason I cannot paste XML in here. The solution is here: It is not the post marked as answer but the one from Robert Barrueco.