Get-nlbclusternode command not found

I just installed two Windows 2012 R2 Data Center servers update the power shell to v5 on both.

They are VM’s on VMware Esxi Hosts

The are both running NLB Network Load Balance Feature.

From my Desktop I ran these commands

$session=New-Pssession -ComputerName tgcs022-n1,tgcs022-n2

invoke-command -Session $session {add-windowsfeature rsat-nlb}

Command was successful on both servers.

 

On the server I ran this command

get-nlbclusternode | format-list *

get-nlbclusternode : The term ‘get-nlbclusternode’ is not recognized as the name of a cmdlet, function, script file,
or operable program. Check the spelling of the name, or if a path was included, verify that the path is correct and
try again.
At line:1 char:1

  • get-nlbclusternode | format-list *
  • CategoryInfo : ObjectNotFound: (get-nlbclusternode:String) [], CommandNotFoundException
  • FullyQualifiedErrorId : CommandNotFoundException

any ideas

Happy new year to all

Thank you

 

Tom

 

 

So, are you also saying, you are not seeing any of the nlb / clustering cmdlets?

Yes none of them show up

Do I need to import a module first? if so which one?

You have to import the session.

Implicit PSRemoting is always:

Establish the session to the host which has the cmdlets you want to use.
Import the Session of the host which has the cmdlets you want to use.
Use the cmdlets in that session.

$NlbSession = New-PSSession -Computer $NlbSrverName
Invoke-Command -session $NlbSession -scriptblock { 
    # This only needs to done once
    If(Get-WindowsFeature 'Rsat-NLB' | Where-Object {$_.Installed -match 'False'} )
    {Add-WindowsFeature Rsat-Nlb}

    Import-Module '*nlb*'
}
Import-PSSession -session $NlbSession

If you are doing this at the consolehost or VSCode, they will show up.
If you are doing this in the ISE, then you have to hit that ‘Commands’ tab refresh button first, in order for them to show.

Also, why do you have multiple servers listed.

$session=New-Pssession -ComputerName tgcs022-n1,tgcs022-n2

Sessions are a 1:1 thing.

$session1=New-Pssession -ComputerName tgcs022-n1
$session2=New-Pssession -ComputerName tgcs022-n2

User error here.

 

RSAT-NLB was installed by the commands I used.

Problem was I was using the 32 bit version of powershell on the server

PS C:\util> get-nlbclusternode

Name State Interface HostID


TGCS022-N2 Converged NLB 2
TGCS022-N1 Converged(default) NLB 1

Working you can lock this as resolved

 

Thank you