Broken my Shell

Hi All,

Apologies for what probably is a stupid question.

Running Windows 8.1 Pro, installed the Azure AD Module, and SharePoint Online Module (which required .net 3)

I went to enable some additional features like telnet client with an add-windowsfeature but I got the error cmdlet unknown. Same thing with Get-WindowsFeature, or Install-WindowsFeature.

I tried the same in ISE, it is like these cmdlets don’t exist anymore.

Im not sure where or how to go about troubleshooting missing cmdlets.

Any help?

sfc /scannow came back fine (as expected)

so I found that the servermanager module is completely missing.

I have copied it from another PC but that did not help.

PS C:\Windows\system32> import-module servermanager
import-module : The module to process ‘Microsoft.Windows.ServerManager.PowerShell’, listed in field ‘NestedModules’ of
module manifest ‘C:\Windows\system32\WindowsPowerShell\v1.0\Modules\servermanager\servermanager.psd1’ was not
processed because no valid module was found in any module directory.
At line:1 char:1

  • import-module servermanager
  •   + CategoryInfo          : ResourceUnavailable: (servermanager:String) [Import-Module], PSInvalidOperationException
      + FullyQualifiedErrorId : Modules_ModuleFileNotFound,Microsoft.PowerShell.Commands.ImportModuleCommand

So apparently ServerManager is not part of 8.1 :frowning: always the last to know.

Anyone have any links to why? how?

Check to make sure you still have the Server Manager feature installed under Control Panel -> Programs and Features -> Turn Windows Features On or Off. The PowerShell module and the Server Manager console get installed together; it’s under “Remtoe Server Administration Tools”.

Well as it turned out, I didn’t have the RSAT installed at all yet (new install). I didn’t realise there had been this change though, its probably too far back to remember accurately but I thought with windows 7 ServerManager was available by default, certainly the add-windowsfeature cmdlet worked against the local computer.

Of course none of the documentation I have read on TechNet suggests that RSAT is required, but I guess that could just be that I haven’t found the right page yet!

Windows 7 doesn’t include the ServerManager module, no. It’s in the RSAT. And the one for Windows 7/Win2008 is pretty different from Windows 8/Win2012, although the newer ones include some aliases to help keep things looking the same.