Error - ‘install-module’ is not recognized as the name of a cmdlet

Hi, I am getting error when trying to install modules, any module. “install-module’ is not recognized as the name of a cmdlet,etc”

I have tried to follow ( https://powershell.org/forums/topic/the-term-install-module-is-not-recognized-as-the-name-of-a-cmdlet/)

I have downloaded the PowerShellGet, changed to zip and extracted files, delete the 4 items. Rename folder ‘fix.fix’ move the folder to one of the main module directories ( C:\WINDOWS\system32\WindowsPowerShell\v1.0\Modules) - still nada - its not even picking up the module (yep rebooted pc and checked again)

Windows 10, enterprise - use ISE and primalscript

Just tried another suggestion I saw in another posting - tried to install-module in psx86 and it let me install modules -hmmm - so the then ran

Install-Module -Name PowerShellGet -RequiredVersion 2.2.4.1 -Force -allowclobber - it worked

Then from normal PSx64 installed another module and it worked. Not really sure the cause but I know a fix for life now :slight_smile:

 

-p.s. - not sure how to close this or if I can.

Hi, sorry to say something is still wrong. I went to install another module ins PSx64 and it said samething as before - "install-module’ is not recognized as the name of a cmdlet,etc”

If I run I use PSx86 it lets me install modules.

Thoughts on issue and fix?

Yeah that makes no sense. Can you do an output of $psversiontable in both consoles and provide the output?