Creating Windows Failover Cluster in Azure using DSC

Hi Everyone,

I know I must be doing something wrong, but I cannot figure out what. With DSC I can get it to create the cluster (this is the Windows Failover Cluster, not a SQL availability group) on whatever node happens to get to that part of the code first. But when adding the other nodes is when it goes wrong. I believe it’s because Get-Cluster test-cl (where test-cl is the cluster object) does not work, the error being RPC is not available. If I go to the node where the cluster was created, let’s call it TestServerA, then that works fine. Get-Cluster TestServerA.

This points to the internal load balancer we have set up. I’ve tried using a lb rule for WSMAN, and even a standard LB with HA-Ports opening up all ports. Still no luck.

Before I bang my head against it any more, just want to know if anyone has ever gotten this to work in Azure? On-prem? We’ve created other clusters without the Get-Cluster command working through the GUI but this seems to be a show stopper for xFailoverCluster.

Any help would be appreciated.

Honestly, you might get a broader response on someplace like ServerFault.com. What you’re dealing with is really an Azure thing, deeply related to Azure networking as you surmise; it’s not really a PowerShell thing other than it’s PowerShell running up against the networking problem.

As a follow-up to this, I discovered that the ILB in Azure simply doesn’t support RPC in any way so until Microsoft rewrites Failover Clusters to use WSMAN you have use a node name when using Get-Cluster. Had to do a pretty major re-write of xFailoverClusters because of this.