VS Code highlight problem

Hi guys,

when i type a cmdlet in vscode, the highlight covers the cmdlet name, how can i fix that ?

thank you

File Menu | Preferences | Color Theme and choose one that isn’t PowerShell ISE

well … i intentionally chose powershell ise mode … so you’re saying i cannot fix that unless i change the theme ?

That’s the quick fix :slight_smile:

You have to get down and dirty with a bit of JSON to customise the themes.

File Menu | Preferences | Settings
On the user blade, expand Workbench, then select Appearence
Under Color Customizations, click Edit in settings.json
In the workbench.colorCustomizations node add

"editorSuggestWidget.focusHighlightForeground": "#ffff00"

You can edit the hex value to change the colour. The value I’ve given it sets it to yellow.

If you want to modify something other than the text colour, there is a full list of themable colours here:

1 Like

thank you man … this solved it … how can i mark your answer as best answer

Happy to help.
I believe you should see a check box next to the :heart: which lets you mark the post as the solution.