Using DSC Pull server to configure a new pull server

Hello,

I’m trying to use the xPSDesiredStateConfiguration resource to configure a new pull server.
Here is the set up:

Current pull server set up at: http://server1:8080/PSDSCPullServer/PSDSCPullServer.svc/
Pull server has version ModuleVersion = ‘3.0.0.0’ of xPSDesiredStateConfiguration in this folder c:\Program Files\WindowsPowerShell\Modules\xPSDesiredStateConfiguration (and for fun and troubleshooting) in c:\Program Files\WindowsPowerShell\DscService\Modules\xPSDesiredStateConfiguration

Set target server to pull mode:
Configuration SetPullMode
{
param([string]$guid,[string]$ComputerName)
Node $ComputerName
{
LocalConfigurationManager
{

		ConfigurationMode = 'ApplyAndAutoCorrect'
		ConfigurationID = $guid
		RefreshMode = 'Pull'
		DownloadManagerName = 'WebDownloadManager'
		DownloadManagerCustomData = @{
			ServerUrl = "http://server1:8080/PSDSCPullServer/PSDSCPullServer.svc'"
			AllowUnsecureConnection = 'true' }
        RefreshFrequencyMins = 5
        ConfigurationModeFrequencyMins = 15
        RebootNodeIfNeeded = $true
       
	}
}

}
$guid = “35a8dafb-eb8d-4b19-96c4-33274c7c1445”
$PullServers = “newPullServer01”
$PullServers | %{SetPullMode –guid $guid -ComputerName $_}
Set-DSCLocalConfigurationManager -Computer $PullServers -Path ./SetPullMode –Verbose

When the target server connects, it logs the following error:
Cannot find module xPSDesiredStateConfiguration.3.0.0.0 from the server http://server1:8080/PSDSCPullServer/PSDSCPullServer.svc/Module(ConfigurationId=‘35a8dafb-eb8d-4b19-96c4-33274c7c1445’,ModuleName=‘xPSDesiredStateConfiguration’,ModuleVersion=‘3.0.0.0’)/ModuleContent.

Any ideas what I have wrong?

Thanks,

Mike

When you configured the current Pull server, where did you set the ModulePath to? That is where the xPSDesiredStateConfiguration Resource needs to live. The Resource also needs to be named like ModuleName_Version.zip, and you need a Checksum file for the Resource .zip file as well.

Here is my ModulePath:
ModulePath = “$env:PROGRAMFILES\WindowsPowerShell\DscService\Modules”

I have zipped up the folder and called it xPSDesiredStateConfiguration_v.3.0.0.0.zip.
Then I ran: New-DscChecksum “$env:PROGRAMFILES\WindowsPowerShell\DscService\Modules”

I now have the Zip file and the xPSDesiredStateConfiguration_v.3.0.0.0.zip.checksum file in the ModulePath.

I reran the pull request, and still get the same error.

Whoops, ok I reread the section from the DSC Book, and see that there is no ‘v’ in the version.
I renamed xPSDesiredStateConfiguration_v3.0.0.0.zip to xPSDesiredStateConfiguration_3.0.0.0.zip, reran the pull and now it seems to be working.

Whew!
Thanks again.