Update-help in VS Code/pwsh.exe doesn't seem to work

As often as possible, I run the command:

Update-help -force -ea 0 -ev ErrMsgDetail
whenever I run Powershell 5.1/ISE or Powershell Core (pwsh.exe).

However, I’ve noticed lately that when I run VS Code with pwsh.exe as shell, the command doesn’t respond. It just sits there forever, with no messages or any feedback. After a few keyboard strokes, I get the shell prompt back. But when I go directly to Powershell Core (pwsh.exe), the command works just fine. Is there some technical reason for this, or perhaps some of my settings are not right? Would be grateful for any advice or guidance.

Why not set this as a background job using a scheduled task, weekly, vs worrying about doing this in the ISE or VSCode interactively. I’ve done this background job thing for a very long time, so, I never have to think about this.

If you want to be sure, then run it this way…

Update-Help -Force -Verbose

Every once in a while VSCode will hang or appear to stop working for any number of reasons. Just reload (hit F1 and type reload and hit enter) or fully restart VScode and try again.

Many thanks, Postanote … much appreciated.

no worries