Update-Help error

by willsteele at 2012-08-22 09:43:19

I frequently run into errors like this with Update-Help. Is there any easy fix?

PS C:\Windows\system32> Update-Help
Update-Help : Failed to update Help for the module(s) ‘ISE, PSWorkflowUtility’ with UI culture(s) {en-US} : The value
of the HelpInfoUri key in the module manifest must resolve to a container or root URL on a website where the help
files are stored. The HelpInfoUri ‘http://technet.microsoft.com/library/jj149011’ does not resolve to a container.
At line:1 char:1
+ Update-Help
+ ~~~~~~~~~~~
+ CategoryInfo : InvalidOperation: (:slight_smile: [Update-Help], Exception
+ FullyQualifiedErrorId : InvalidHelpInfoUri,Microsoft.PowerShell.Commands.UpdateHelpCommand
by DonJ at 2012-08-22 09:49:11
Well, no. That URL currently goes to a Web page, not a help file update, which is not what the command is expecting. That might get fixed once they actually post all the help, but there’s not much you can do on your end.
by willsteele at 2012-08-22 09:58:39
Ok, so long as it is just something that will get resolved in time. I see the -Force switch allows me to reload more than once a day, but, do you know of a way to continue retrieving other topics once I get an error? I tried this and it still stops on error.

Update-Help -Force -ErrorAction Continue
by DonJ at 2012-08-22 10:05:58
I’ve not see that behavior… I’ve always seen it just keep going after spewing an error. You’re running into a harsher error than I have been, I think ;). But no, if the command spews a terminating error, it’ll just quit-quit-quit. I guess if you have a specific module you could just attempt to grab it’s help. You could probably manually enumerate the modules and try to Update-Help for each one - that’d let you continue past an error. See options at http://technet.microsoft.com/en-us/libr … 49720.aspx.
by juneb_msft at 2012-08-24 10:43:05
Great post, Will. The Updatable Help topics for these modules have been available since RC, so any failure is a bug. I found the cause of the error for the ISE module (my fault, ugh!) and I’ve alerted my hardworking colleagues to the failure in the PSWorkflowUtility project. I’ll get these fixed ASAP.
by willsteele at 2012-08-24 12:20:17
Great. Thanks for letting me know June. I guess it may be worth letting you know. I have had a lot of documentation issues in the past and just assumed it was me. If I run into any more, do you want me to email you or open Connect tickets?
by juneb_msft at 2012-08-29 16:36:29
This is fixed! We just released Updatable Help for the ISE and PSWorkflowUtility modules. Thanks so much for letting me know that it was missing. I’ve instituted a process to monitor the releases so this doesn’t happen again.

Please try it!

– Start Windows PowerShell with the "Run as administrator" option.
– Update-Help
– Update-Help -Module ISE, PSWorkflowUtility

Will, of course, you should let me know. You can send me email or file a bug on Connect.

Thanks again,