Service Manager DSC - Package command line arguments not working

I can’t seem to get this Service Manager DSC package to kick off properly. After execution of the config, I can see the SCSM install wizard fire up in task manager, but it closes within minutes, and DSC throws a -252 error. I’ve tried and tried to dig into logging, verbose, debug, etc, I can’t seem to figure out exactly how DSC is parsing the arguments and executing them. I’m sure it’s just parsing them wrong, and executing on them incorrectly. There’s a few escaped characters for " and \ but it all seems to be correct.

Arguments from MOF file of DSC configuration

Arguments = “/silent /install:Server /AcceptEula /ProductKey:“XXXXX-XXXXX-XXXXX-XXXXX-XXXXX” /AdminRoleGroup:APD\Domain Admins /CreateNewDatabase /Databasename:ServiceManagerTEMP /SqlServerInstance:SQLSERVER /ServiceRunUnderAccount:DOMAIN\account\password /WorkflowAccount:DOMAIN\account\password /ManagementGroupName:MGMGRP /EnableErrorReporting:Yes /CustomerExperienceImprovementProgram:No”;

Command line that works via manual execution

/silent /install:Server /AcceptEula /ProductKey:“XXXXX-XXXXX-XXXXX-XXXXX-XXXXX” /AdminRoleGroup:APD\Domain Admins /CreateNewDatabase /Databasename:ServiceManagerTEMP /SqlServerInstance:SQLSERVER /ServiceRunUnderAccount:DOMAIN\account\password /WorkflowAccount:DOMAIN\account\password /ManagementGroupName:MGMGRP /EnableErrorReporting:No /CustomerExperienceImprovementProgram:No

Any ideas? I’d love to know how to find out exactly what command line DSC is executing, but I can’t seem to find any logs that would show me that information.

NM, realized it was a user session / credential problem. Still haven’t found a way around it. These pesky UI applications don’t deal well with DSC… YET!