RebootNodeIfNeeded appears to no longer be working


I have been working on using DSC to setup our test web servers. Part of the DSC script is to install coldfusion which requires a reboot. I swear, a few weeks ago this was working famously and the vm would reboot after installing coldfusion.

I resumed testing and developing today and the reboot portion of the program is no longer working, even though all signs say it should be.

Here is the LCM configuration on the target machine:

ActionAfterReboot              : ContinueConfiguration
AgentId                        : EC3F61DA-5D5D-11E5-9745-00155D010277
AllowModuleOverWrite           : True
CertificateID                  :
ConfigurationDownloadManagers  : {[ConfigurationRepositoryShare]DSCSMB::[LCMPULL].::[LCMPULL].}
ConfigurationID                : 5867bd2d-56d8-4a8b-8e31-36636dacf04e
ConfigurationMode              : ApplyAndAutoCorrect
ConfigurationModeFrequencyMins : 15
Credential                     :
DebugMode                      : {NONE}
DownloadManagerCustomData      :
DownloadManagerName            :
LCMCompatibleVersions          : {1.0, 2.0}
LCMState                       : PendingConfiguration
LCMStateDetail                 :
LCMVersion                     : 2.0
MaxPendingConfigRetryCount     :
StatusRetentionTimeInDays      : 10
PartialConfigurations          :
RebootNodeIfNeeded             : True
RefreshFrequencyMins           : 30
RefreshMode                    : Pull
ReportManagers                 : {}
ResourceModuleManagers         : {}
PSComputerName                 :

I can even see in the verbose output of update-dscconfiguration that the server knows it needs to reboot:

VERBOSE: [QWDSC01]: LCM:  [ Start  Set      ]  [[Package]coldFusion]
VERBOSE: [QWDSC01]:                            [[Package]coldFusion] Validate-StandardArguments, Path was PATH
VERBOSE: [QWDSC01]:                            [[Package]coldFusion] The path extension was .exe
VERBOSE: [QWDSC01]:                            [[Package]coldFusion] Ensure is Present
VERBOSE: [QWDSC01]:                            [[Package]coldFusion] product installation cannot be determined
VERBOSE: [QWDSC01]:                            [[Package]coldFusion] product as boolean is False
VERBOSE: [QWDSC01]:                            [[Package]coldFusion] The package Adobe ColdFusion 9 is not installed
VERBOSE: [QWDSC01]:                            [[Package]coldFusion] Validate-StandardArguments, Path was PATH
VERBOSE: [QWDSC01]:                            [[Package]coldFusion] The path extension was .exe
VERBOSE: [QWDSC01]:                            [[Package]coldFusion] Package configuration starting
VERBOSE: [QWDSC01]:                            [[Package]coldFusion] Create log file
VERBOSE: [QWDSC01]:                            [[Package]coldFusion] Mount share to get media
VERBOSE: [QWDSC01]:                            [[Package]coldFusion] The binary is an EXE
VERBOSE: [QWDSC01]:                            [[Package]coldFusion] User has requested logging, need to attach event handlers to the process
VERBOSE: [QWDSC01]:                            [[Package]coldFusion] Starting PATH with -f SILENTPATH
VERBOSE: [QWDSC01]:                            [[Package]coldFusion] Starting process PATH with arguments -f SILENTPATH
VERBOSE: [QWDSC01]:                            [[Package]coldFusion] The machine requires a reboot
VERBOSE: [QWDSC01]:                            [[Package]coldFusion] Package has been installed
VERBOSE: [QWDSC01]:                            [[Package]coldFusion] Package configuration finished
VERBOSE: [QWDSC01]: LCM:  [ End    Set      ]  [[Package]coldFusion]  in 210.0380 seconds.
VERBOSE: [QWDSC01]: LCM:  [ End    Resource ]  [[Package]coldFusion]

As you can see, it says in the verbose output “VERBOSE: [QWDSC01]: [[Package]coldFusion] The machine requires a reboot”. So obviously the machine recognizes it needs to reboot, but it looks like the RebootNodeIfNeeded setting is not working and rebooting the machine as it goes onto the next resource which throws an error because the machine needs to reboot first…

I am running out of rocks to turn over and am baffled by this. Any ideas or thoughts would be greatly appreciated!


I’d try this on a fresh VM as a test. If it continues not to work, and you’re using the latest WMF code, bug it in Connect.