Powershell Scheduler in Windows 10

I am having Powershell 5 tried scheduling a task through this command.The scheduler is working sometimes and sometimes which is not scheduling in Windows 10.Any other faced this issue before or the syntax is different for scheduling.

I have checked the Scheduled status which is showing as Ready only and tried deleting the task and rescheduled which is not happening.I have tried schedule the calc.exe for testing which is opening without any issue.Kindly help to schedule .bat file.The .bat file is working without any issue when runned manually.

Schtasks /create /tn “Test” /sc daily /st 06:00 /tr “C:\Folder\test.bat”

Name Value


PSVersion 5.1.15063.994
PSEdition Desktop
PSCompatibleVersions {1.0, 2.0, 3.0, 4.0…}
BuildVersion 10.0.15063.994
CLRVersion 4.0.30319.42000
WSManStackVersion 3.0
PSRemotingProtocolVersion 2.3
SerializationVersion 1.1.0.1

The machine is locked state only not even signed out.

Windows 10
Windows Version 1703(OS Build 15063.994)

I would opt for the native PS cmdlets rather than trying to use the command line applications where possible.

Check out the options for New-ScheduledTask and see if that’s what you may want to use instead.

Get-Help New-ScheduledTask

Get this error.I have installed 6.1 version

Get-Help : Get-Help could not find New-ScheduledTask in a help file in this session. To download updated help topics type: “Update-Help”. To get help online, search for the help topic in the TechNet library at https://go.microsoft.com/fwlink/?LinkID=107116.
At line:1 char:1

  • Get-Help New-ScheduledTask
  • CategoryInfo : ResourceUnavailable: (:slight_smile: [Get-Help], HelpNotFoundException
  • FullyQualifiedErrorId : HelpNotFound,Microsoft.PowerShell.Commands.GetHelpCommand

Open PS as administrator and call `Update-Help`. Or just do a google search for the help topic to get you up to speed. :slight_smile:

Do also check Get-Command scheduledtask to ensure that the commands are present, although if you’re on win10 they definitely should be. :slight_smile:

https://community.spiceworks.com/topic/2126267-scheduler-issue-in-the-powershell?page=1#entry-7663138/

Tried this suggestion also.Which is not working?

https://community.spiceworks.com/topic/2126267-scheduler-issue-in-the-powershell?page=1#entry-7663138/

Tried this suggestion also.Which is not working?