powershell has stopped working

I am running several powershell scripts at the same time, I need to do this for an automation project. Just about everytime I do this I get a diaglog box that comes up with:

powershell has stopped working

Problem Event Name: PowerShell
NameOfExe: powershell.exe
FileVersionOfSystemManagementAutomation: 10.0.14409.1005
InnermostExceptionType: System.IndexOutOfRangeException
OutermostExceptionType: System.IndexOutOfRangeException
DeepestPowerShellFrame: unknown
DeepestFrame: rvice.ClientManagerImpl.TryGetClientByConnectionId
ThreadName: Client side task:
OS Version: 6.3.9600.
Locale ID: 1033

I tried searching on line for a fix, but haven’t had much luck. Does anyone know what this is trying to tell me.

BTW: the scripts run fine if I run them one at a time. And they continue to run even after this dialog comes up.

Is there some way I can detect that this dialog has come up? So that I could kill the process so I could continue on.



It is possible that your system cannot handle the load(unlikely, but possible)

verify your RAM specs and ensure each module is good, a faulty module causes erratic issues and i have had this happen before myself and found that one of my RAM modules had crapped on me.

best test is to watch your resource monitor whenever your running the project scripts and see how it runs there.

This could be because of raise conditions between scripts as they are running in parallel. You could try running different scripts in different combinations for debugging.

Hi There!

I have had this issue as well with large long running script that cause the ISE to crash. The ISE function is for debugging your scripts and not running code, though we have all be guilty of this ;-p. As kvprasoon stated, this can be due to memory limitations as well as debugging issues.

These scripts are best suited to be run in PowerShell.exe rather then the ISE.


I am not running these script under the ISE, I am running them from the command line. I am running several of these script in parallel and the cpu usage is getting up to 100%. I can reduce the number of script running in parallel, but I would still like to have some kind of monitor to detect this error so the monitor could recover from this. I was looking at get-process to see if this dialog was up, but it doesn’t seam to be listed. When I run the get-process I can find some powershell process like:

Handles NPM(K) PM(K) WS(K) CPU(s) Id SI ProcessName

430 22 46164 43540 0.16 131952 2 powershell
602 30 60300 61912 0.50 141844 2 powershell
474 24 60076 58108 0.31 145480 2 powershell

Does anyone know what this dialog box process name would be? Or even if its listed by get-process.