Package Management (OneGet) Issues

EDIT: I figured it out 1 minute after posting. Installing packages from an untrusted provider requires changing the PS execution policy…duh.

Hello all, I’m confused about OneGet (or whatever it’s called these days).

I think I’m probably doing something silly, but there are not a lot of people around the web talking about this so it’s been hard to get information via googling.

I am not able to get anything to install via the Install-Package module. I mean I used to, but now it seems to just not be working. But let me explain what I mean by “not working”.

Let’s say I install Vagrant: Install-Package -ProviderName Chocolatey -Name Vagrant

Yay! It completes the install (seems way too fast actually), and everything looks fantastic at first. But I don’t see Vagrant listed under installed applications in the control panel. I don’t see it in the default location.

Then I run Get-Package -Name Vagrant – Sure enough it is there. It appears to be installed. But the source returned by Get-Package is in a weird place; it’s in C:\Chocolately\lib\vagrant.1.8.5.

So I look in there and I see vagrant.1.8.5.nupkg, chocolateyinstall.ps1, and chocolateyuninstall.ps1

The files for the install are there, but that’s it. If I remove those files, then Get-Package no longer detects it. So I tried this with Virtualbox, Git, and some other stuff; I got the same result with all of them.

Any ideas?

And it’s PowerShell Package Manager now ;). Glad you got it!