OneGet - Chocolatey Package Provider is Absent

Hey guys,

I wanted to play around with OneGet and seem to be having an issue. After installing WMF 5 when I run the Get-PackageSource command I get the output shown in the attached file.

According to what I understand OneGet should ship with Chocolatey being the primary package provider. I have also tried running the Register-PackageSource cmdlet like so:

Register-PackageSource -Name chocolatey -ProviderName Chocolatey -Location http://chocolatey.org/api/v2/

The output from that is “Warning: Unable to find package provider ‘Chocolatey’”

Any help is appreciated. OneGet looks awesome.

I believe the latest version of OneGet over at https://github.com/oneget/oneget/ has this resolved. By the time everything is fully released, Chocolatey will be back in the box. :slight_smile:

Thanks for the reply Dave. Pardon my inexperience with source control but which piece(s) from that link should I pull down in order to use the current version? Would it require building the code?

Just searched through my email, and found this link to download the latest build: http://oneget.org/oneget.zip