ISE intrellisense not working after spring 2018 update?

Hi, I just noticed that intellisense in the ISE has stopped working on both of my machines. Where intellisense would have triggered, there is now a gray dot underneath the line. Has anyone else run this? I’m wondering if it has to do with the Win10 (home ed.) spring 2018 update from earlier in the week, as it seems odd it would just break on both machines at essentially the same time.

Given that ISE is deprecated, and as a troubleshooting step, are you able to try in VS Code?

Thanks for replying so quickly- VS code works fine, so I will have to switch to it I suppose. RIP Commands add-on.

… and snippets do not work anymore either …

I have several systems that are on the WinInsider builds, slow, fast, and skip ahead (all on the latest WI builds as of this week) and none of them are having these issues.

So, this is specific to this 1803/1809 releases as far as my tests have confirmed thus far.

VSCode is independent of the OS. Unlike Win PoSH. So one could assume it would not be impacted by an OS upgrade as it can easily uninstalled and reinstalled as needed. Even going back to earlier versions. Not so with Win PoSH.


Given that ISE is deprecated, and as a troubleshooting step, are you able to try in VS Code?

Though depreciated, MS has said it will be in and work as is in future version, and only fixes, but no more new stuff.
I’d call this a bug fix. So, yeah, this is unacceptable, since in WS2016 and the pre-stuff for WS2019 it still works as expected.
As well as the aforementioned WinInsider builds where it is still working as expected.

So, someone / some team at MS obviously missed this in QA/Test sprints and for us who still rely on the ISE (even more so for us with heavily customized and several add-ons, including paid for ones like ISESteroids, lots of custom snippets, etc…), this is problematic, and actually unacceptable. I understand depreciated, but to intentionally (maybe unknowingly - but I doubt that) break it without cause / announcement is foolish and customer experience negative.

And before someone kick back at me, 8^} - cause I know it can happen, I have several tools I use for PoSH work, SAPIEN’s PowerShell Studio for major projects / GUI / Exe level stuff, ISE for daily use, VScode for other stuff. I stick with ISE over VSC for daily stuff because of all that things that the command pallet and other add-ons provide for my daily PoSH needs / use that VSC does not provide and I know of no plans to provide it. I live in VSC on Linux and OSX (but I rarely use these systems except for very specific needs), but not on Windows proper.

So, sure, I can bounce to SPS, VSC, or just live on my WinSider builds (not really a thing - these are test boxes and not what myself and my team use as daily drivers) but still, u know, 95+% of my/our time is in the ISE across the enterprise environment.

So, I now have to halt / block all Win10 spring edition upgrades as of me discovering this on install today.


Snippets still work, but hitting the CRTL+J or selecting it from the edit menu does not display the stored snippet list.
Either approach, just shows a small ‘.’ on the screen, where the list is to be displayed.
If you know the name of your snippet or part of it, type that part of the name and hit enter, the snippet will populate in the editor.

I’ve not tried to post a video here or I would showing this.

The other option, is to write your onw menu option (using a different hotkey combo) for the Add-Ons section and select from there. Of course that is, first writing the necessary code/function to grab your snippet content to display in the ISE or use GCI on the snippet directory to show the names, then use CRTL+J and at the dot, just type the beginning and hit enter.

These are just the workarounds I came up with today to deal with this until MS can get a fix.

BTW, other modules / add-ons can still fail, depending on what they are. For example the ISEMobuleBrowser from the MS PSGallery fails hard / crashes the ISE.

Lastly, though the auto popup list don’t happen, tab complete still works as does just using he command palette