Getting an Error, not sure why???

I’ve attached a screen shot of the error. This was not happening a few days earlier, but now this is happening I run the script from a workstation, it in turn will run a batch against a network server. This was working fine but today I’m getting errors. I fo to run the same code on the network server locally so I can see what the issue is and the error attached is what I see.

Any Idea as to what would cause this?



Additionally, I wanted to just see if I can invode a simple command from the same server, using localhost, I figured this could test if pssessions is working correctly, maybe :). The results were:

PS Z:\> Invoke-Command -ComputerName localhost {Get-Service -Name 'Nuix Server 4'}
[localhost] Connecting to remote server localhost failed with the following error message : Access is denied. For more information, see the 
about_Remote_Troubleshooting Help topic.
    + CategoryInfo          : OpenError: (localhost:String) [], PSRemotingTransportException
    + FullyQualifiedErrorId : AccessDenied,PSSessionStateBroken

So I’m thinking something may have changed with the configuration of the psremoting or pssessions??? What do you/anyone think??

Also, I closed the ISE, then reopened it with Run As Administrator, ran the same code and it worked fine. So, not sure why, but all of a sudden, I can only get the expected results of a pssession if we run powershell as Admin. but this was working fine before. So what could have changed???

It is hard to determine what and why something changed on your system. Perhaps a new group policy applied to your system, maybe and old policy that previously didn’t completely apply finally worked. The test you describe is different as you are contacting a different system. What is the exact code you are executing and are you using the -Credential parameter or are you using the current logged on user?

uses current user, not passing creds…after comparing to other servers that aren’t seeing this issue, I found a discrepancy. For the servers that are working as expected, they have the following permissions set:

Powershell Session Users AccessAllowed

The servers that are requiring Run As Admin do not have that permissions set…

Does that look like it could be the issues?