Access is denied - PSRemoting


I have created a Windows 2012 R2 VM to experiment with some DSC Configuration. I have created two local users and have added them into the Administrators local group.

I have attempted to PSRemote into the server using the two newly created users.

I have tried to create a session like this:

$cred1  = Get-Credential 

$nsn1 = nsn -ComputerName -Credential $cred1

But I get a access is denied. I have confirmed that I can log in locally using the same credentials. It works, so I am a bit baffled as to why its not working as in the help with about_remote_troubleshooting it’s saying that the users need to be in the local administrators group which I have added in these users too…

I have added the server to the trustedhosts as well…
I am sorry if this seems a bit basic but I don’t understand what I am missing. Any help or guidance what I should be looking for would be most appreciated.

Hi Tan,

Is PowerShell remoting enabled on remote host ?

It would be better to read the help for about_remote_troubleshooting, everything you need is mentioned there.


Hi there Wei-Yen. Is the machine on the domain? If so, can you post the error message you’re receiving?

Remoting does work on the administrator. I thought that I would try and run winrm quickconfig on the destination server. and realized that local users are not added to the list of usrs that can remote in…EVEN if they are in the list of local administrators. Once i ran quickconfig it all worked. Learn something new every day. :slight_smile:

Thanks for everyone’s help.