Error remote comand


If I am trying:

Get-Process -c $comp -name chro* | Stop-Process
I have the following error:

“feature is not supported in remote machine”

If I use the command Get-Service with pipeline for services it’s working. Last week I was able to stop a process with this command, but now I have this error for all the computers.

I tried also with Get-WmiObject -Class Win32_Process:

(Gwmi Win32_Process -c $comp | ? {$_.ProcessName -like “chr”}).Terminate()
but it’s not working, and I don’t have errors.

I cannot use Invoke-Command because PSremoting is disabled.

Can you run this locally on your machine? Can you log into that remote machine and do it there?

@Alex Yes, loccaly get-process chr* | stop-process it’s working on both machine.
I will try with WMI class locally also to check.
I need this command for some scripts, and i don’t want to use psexec to much. PSRemoting is disable.

Try Below

$Process = ""

$Killme = Get-WmiObject win32_Process -ComputerName ACHRCNB0900X409 -Filter "name='$Process'"

IF(!($process -eq "")){



@Matt i tried, but it’s not working. The process is still running.