Disable Quick Edit

I’m trying to figure out how to disable the Quick Edit setting, seems with this setting enabled, the shell will freeze in some instances, if running a large job. And the registry setting is in HKCU, so I can’t set it by default for all users. Is there a way to set a profile for the console that removes that default setting: Or any other ways, without admin privileges???

Hey Mate,

If you really wanted to disable it, simply right click up the top of your powershell console, head down to properties and under Edit options you will see ‘QuickEdit Mode’.

This only works for the current user though, I was wondering if anyone new of a way to programmatically disable that setting when a script is run. Ideas?

It’s a registry setting:

http://www.windowsnetworking.com/kbase/WindowsTips/WindowsXP/RegistryTips/Commandshell/EnableQuickEditModeinWindowsXPCommandShell.html

Although this is for XP, I’m sure it’s comparable in later OS’s

Tested this one already, even a change in the registry doesn’t change the property in the console…What I found is if you call the powershell.exe on a 2008 server, the quick edit mode is not enabled, but if you just double click the icon from the start menu it will be enabled. However, in Server 2012, it is enabled no matter how you call the executable…only way to disable it is to manually disable it in the properties…I saw that you can create a profile for the powershell console, do you know how to set the Enable or Disable for Quick edit in a profile? I did not see anything…

What are you trying to accomplish? What are you trying to prevent?