working with self made dlls in assembly

i created dll called myTools.dll, put it in the GAC (assembly), and i see it there.
i want to load this dll and access it’s static methods.
i tried to do
Add-Type -AssemblyName myTools;
and get error that

Add-Type : Cannot add type. The assembly 'myTools' could not be found.

any idea?what do i miss?

How did you add your assembly to the GAC? If Add-Type is failing, odds are that wasn’t done properly. See this link.

drag and drop to the assembly
i accees it with no problem from web pages.

when i do


this works.
can i some how access like this the static methods?

I’m pretty sure you’re not adding the assembly to the GAC properly if you just dragged and dropped a DLL into that location, but I’m not certain. Anyhow, if that call to Assembly.LoadFile works, then you should be able to load it this way with the Path parameter instead of AssemblyName:

Add-Type -Path 'C:\Windows\assembly\GAC_MSIL\meTools\\myTools.dll'

this way worked
Get-ChildItem -recurse “C:\Windows\assembly\GAC_MSIL\myTools\”|Where-Object {($.Extension -EQ “.dll”) -or ($.Extension -eq “.exe”)} | ForEach-Object { $AssemblyName=$_.FullName; Try {[Reflection.Assembly]::LoadFile($AssemblyName)} Catch{ "ERROR Not .NET assembly: " + $AssemblyName}}