Verified Effective Test in July newsletter

Have anyone played around with it?

the first lines go like this:


Windows PowerShell transcript start
Start time: 20150602172842
Username : COMPANY\Administrator
Machine : WIN81 (Microsoft Windows NT 6.3.9600.0)


This is not how it looks like on my PC, well only if I run it with "Powershell.exe -version 2"

On my PC I get this:


Windows PowerShell transcript start
Start time: 20150910123639
Username: WIN-0627Q340HBN\Administrator
RunAs User: WIN-0627Q340HBN\Administrator
Machine: WIN-0627Q340HBN (Microsoft Windows NT 6.3.9600.0)
Host Application: C:\Windows\System32\WindowsPowerShell\v1.0\powershell.exe
Process ID: 2460


Also the “help get-corpsysinfo” give no output, this is not the case with on my pc, unless I run with PSv2.

Sure I could make a function to replace the default help cmdlet, but I cant change the “headers” that “start-Transcript” output.

Also the transcript output paths and which commands are typed in, this is also not true for higher than powershell version 2, atleast I cant find a way to make transcript dump that info also.

I wouldn’t worry about the transcript header; that’ll vary based on PowerShell version.

I did a write-up on the self test here: https://davewyatt.wordpress.com/2015/07/18/my-take-on-the-verified-effective-self-assessment/ . As far as the blank output of help, I cheesed it by just writing “function help {}”. :stuck_out_tongue:

Hey Dave,

yeah I did see your blog post, but do you get the typed commands in the transcript?

So if large part of the transcript are not to follow/replicate, which part are then? :slight_smile:

it seems that this test were based on an older one? that were made on V2.

also that “function help {}”
This only work if the module is preloaded or the function is made before the transcript start.

and I really do think that this hack is counterproductive in an test to show skills :wink:

but the help in the transcript do with just like in Powershell Version 2, as that don’t automatisk create that basic help like newer powershell do.

You’re not meant to worry about the transcript header. Everything else. And it wasn’t made in v2. But it’s potentially a way to find gaps in your knowledge!

Oh no, My problem were not running with windows 8.1, but I made a Windows server 2012 R2. (I had that Iso locally.)
After downloading a windows 8.1 I got the transcript right.

Oh well, back to the scripting :slight_smile:

I wonder why there is a different this huge.

Ah and that help get-corpsysinfo do output to console, but it’s not written to the transcript.
so that is also just fine, no need for the “function help {}” hack.

Here is my take on it. feedback are welcome :slight_smile:
http://1drv.ms/1Og6vIE