Trying save a WindowsImageBackup to a WD My Cloud Home Duo

I’m a newby. The following script doesn’t work but I don’t know why. For any successful help, I promise to be your butler for the first gazillion years in the afterlife (Thursdays off).

PS C:> WBADMIN START BACKUP

[-backupTarget:{\\MYCLOUD-123456\Public}]
[-include:C:\Users\Documents]
[-allCritical]
[-user:My Cloud Home\widow.twanky@tatmail.com]
[-password:wottamess]
[-noInheritAcl]
[-noVerify]
[-vssCopy]
[-quiet]

At line:2 char:6

  • [-backupTarget:{\\MYCLOUD-123456\Public}]
    
  •  ~
    

Missing type name after ‘[’.
At line:10 char:6

  • [-quiet]
    
  •  ~
    

Missing type name after ‘[’.
+ CategoryInfo : ParserError: (:slight_smile: , ParentContainsErrorRecordException
+ FullyQualifiedErrorId : MissingTypename

Robert,
Welcome to the forum. :wave:t4:

First and foremost you should start with learning how to read the help. Arguments or parameters enclosed in square brackets are optional. That means you don’t have to provide them. But if you do you do it without the square brackets. :wink: Here you have some more stuff to read about:

Last but not least … WBADMIN is not a PowerShell cmdlet - it is an external tool. It does not follow PowerShell syntax rules and it does not accept or outputs PowerShell objects.

If you want to use PowerShell cmdlets to manage your backups you can use the WindowsServerBackup cmdlets:

1 Like

Thank you for your response. My first reaction is to say that I very much doubt that anything to do with WindowsServerBackup would work because using the WindowsImageBackup in Windows 11 (and 10) simply doesn’t work with the WD My Cloud Home Duo device. The evidence that it simply isn’t designed to do so is now pretty substantial (including a chat with a WD technician a few hours ago, who, after lengthy exchanges, eventually stated that the product did not support the WIB function). [Windows 7 was supposedly, according to him, the last Windows version able to do the job, and I tested it this evening with an old machine and it simply doesn’t work.]

So, following remarks by various people in different websites about Linux and PowerShell, I’m trying to see if success is still possible, but I have only three days before taking the WD product back to the store before the deadline. I think I must forget about Linux because I know nothing about it. I’ve looked at two “user manuals” which are both very badly and confusingly written. What I need is something like a PowerShell for Dummies, which I can start reading at page 1 and go on until I find the syntax of the script I need.

Best wishes,

Rob

Do you want to have a working backup solution or do you want to learn PowerShell. It sounds like you should focus only on one of it for now. :wink:

If you want to have a simple file synchronisation with Windows standard tools you could take a look at robocopy. :wink:

I only have 3 days left, so I’ve only got time for finding a working backup solution for the moment. I’ll take a look at robocopy, but what I’m looking for is a way of making an ImageBackup of my computer which I can frequently update so that, in the event of a a crash, I can run the startup facility to re-install my ImageBackup. I have been doing this using an external HD for several years, but I was hoping a WD MCHD would do the job in the background. The salesmen in the store I went to didn’t know their own product and sold me a pup.

Rob

Have you looked at the built in file history? I believe even the old windows 7 backup and restore was still buried in windows 10. Not sure about 11

You’re right. Win7 Backup and Restore IS included in Windows 10 (and 11). The problem is: it doesn’t work with WD MCHD. I know because I tested it with an old Win7 computer early this evening. File Explorer not only recognized the box, but even let me into it. But running the Backup and Restore facility simply doesn’t bring up the network options. I’m restricted to external HD’s connected to the computer by USB.

But I’m grateful for your interest and input.

Best wishes,

Rob

If your drive has a drive letter, a work around in the past was set up backup to c, then go change the drive letter in the registry. Honestly none of the ideas presented here sound like a good idea to protect data you really care about.

Why do you put yourself in a hurry for no reason? Return what you need to return for now and take your time to do your research.
I’m not experienced with ImageBackup solutions but I’m sure there are some affordable and good ones able to use almost anything as the backup target - even a WD MCHD when you provide it with a drive letter in Windows.

BTW: none of this is a PowerShell topic. You may find more or better support in specialized forums for these kind of topics. :wink:

1 Like

Is your script written exactly as you’ve typed it? The error, whereby it’s interpreting the square brackets as a type declaration, suggests to me that you are.

If you’ve not set up a schedule, then the command should be typed all on one line, without the sqare brackets. This test worked for me to a WD Mirror Gen2.:

wbadmin start backup -backupTarget:\\MyNAS\Data\z_Backup -include:c:\users\matt\documents -allCritical -user:matt -password:P@ssword -noInheritAcl -noVerify -vssCopy -quiet

1 Like

I have been playing with wbadmin.exe lately and I can attest to the fact that you CANT use that tool for a granular backup only. In other words, it backs up ONLY complete drives or volumes. You are specifying the following whith wbadmin.exe:

-include:c:\users\matt\documents

If you want granular backups only, in other words, you only want to backup that folder, I would continue on your path with robocopy. Matt, I think you will find that if you look at the backup you ran, you will find that using -allCritical actually backed up the entire drive/volume. If you leave that off, it should give you this error: “A partial backup of volumes is not supported on this version of Windows”

Actually it was the entire drive that I DID want to back up. I just limited it to “Documents” because I thought it would save time in a test. I didn’t realize it wasn’t part of PowerShell. (I can’t actually remember where I got the script basis from.)

That being the case, why do you need PowerShell? What Matt sent you should work from any shell, just set the include to C:

wbadmin start backup -include:C: -backupTarget:\\MYCLOUD-123456\Public -allCritical -user:matt -password:P@ssword -noInheritAcl -noVerify -vssCopy -quiet
2 Likes

Hello, Tonyd.

I would dearly have loved to try your script. In fact, I was going to. I opened File Explorer, to make sure the network was ok, and - lo and behold - it wasn’t. What’s more, nothing worked to restore the familiar arrangements. I even re-set the MCHD.

I should have realized all this was beyond my capabilities because of two things: 1) when I tried to change the password, I followed the instructions scrupulously, but nothing worked; 2) when I checked to see if the thing would work with a Win7 machine, not only did the right screens not appear, but also things were significantly slower afterwards.

So, I’ve re-re-set the damned box, and it’s going back as soon as. I’m also going to reset my new computer to factory settings. My older machine is probably harbouring all sorts of hidden conflicts but I do have a recent restore point so, once I’ve saved all my recent work, I’ll go back to it.

All this will still leave me with the problem of setting up reliable arrangements for a system backup. The ideal thing, I think, would be a device which would allow direct cable connection to my computer so that, in the event of a crash, I could restore to a very recent system image. Any suggestions?

Thank you again. (I don’t think you’ve done enough to earn a gazillion years of butlery, but I’d willingly keep your wastepaper basket empty. Who knows what useful tips I’d be reading. :slight_smile:

Rob

Buy a Mac, use Time Machine! :wink:

Olaf, I could not agree more. Why cant M$ come up with something like Time Machine. They copy everything else from Linux, why not that :slight_smile:
Also DalJenk, if you have permissions to write to the share on the NAS, you can leave out all the username/PW stuff and just use this:

wbadmin start backup -include:C: -backupTarget:\\MYCLOUD-123456\Public -allCritical -quiet

That is what I use and it works well. This is technically not a script, just a command. I have mine setup as a task that runs weekly. In that case, you just supply the creds for the task.

So what do you do instead?

Do instead?? Are you referring to what to do to just backup “-include:C:\Users\Documents” as you state in your original post?

First off, I don’t think that folder will actually exist aside from adding a user in the string like “C:\Users\BadAss\Documents”. If that is indeed your question, I would use and DO use robocopy for that. Google it, tons of examples.

He was replying to me.

To answer that question would take a consultation, as I really don’t know what you have, what you need to protect, your RTO time, etc. There are many backup options, I would choose one that was easy to use and reliable. You may just have to test a few out. It sounds like the current solution you have is neither.

Understood Krzydoug … sorry for my error. Agree with you though, there are many options and many opinions.