Slow PSremoting to Server 2016

I’ll try to make this as simple as possible but I’m looking for someplaces to start looking at troubleshooting.


I have a large environment of 2012R2 and Server 2016 servers. When I run commands against the 2012R2 servers they complete very quickly (milliseconds) but when I run same commands against Server 2016 it can take 1-2 mins. To be clear, its not the script itself that is slow, its just connecting remotely to these servers. For instance:

Doing a measure-command against my 2012R2 servers:

Measure-Command {Enter-PSSession -ComputerName 2012R2-01}

Takes 6 milliseconds

Measure-Command {Enter-PSSession -ComputerName 2016-01}

Takes 98 seconds.


Anyone have any ideas on where to start? Thanks.

This sounds environmental vs PS specifically as well as same domain, different domain, Firewall settings validation, any other filtering device in the mix.

You don’t say what your environment is.

So does this occur this way…

WinPS 4x+ —

Source 2012R2 to target 2016
Source 2016 to target 2012R2
Source Win7 to target 2K12R2, 2K16
Source Win10 to target 2K12R2, 2K16

PSCore —
Source OSX/Linux to target 2K12R2, 2K16

I say environmental, because I am not seeing this in any environment I am responsible.
For, example for just one of them -
Single flat AD forest/domain lab instance, using default PSVersions

(Get-CimInstance -ClassName Win32_OperatingSystem).Caption
Microsoft Windows Server 2012 R2 Standard

Measure-Command {
    Enter-PSSession -ComputerName LabIIS01

Days              : 0
Hours             : 0
Minutes           : 0
Seconds           : 0

Milliseconds      : 348  ******

Ticks             : 3485755
TotalDays         : 4.03443865740741E-06
TotalHours        : 9.68265277777778E-05
TotalMinutes      : 0.00580959166666667
TotalSeconds      : 0.3485755
TotalMilliseconds : 348.5755

[LabIIS01]: PS C:\Users\Administrator.Contoso\Documents> (Get-CimInstance -ClassName Win32_OperatingSystem).Caption
Microsoft Windows Server 2016 Datacenter