Remote execution of powershell commands from Linux


I am trying to remotely execute the powershell commands from a Linux and Mac servers. I installed powershell in Mac and tried to run Enter-Session.

PS> Enter-PSSession -ComputerName aaa.bbb.ccc.ddd

Unhandled Exception: System.NullReferenceException: Object reference not set to an instance of an object.
at System.Management.Automation.Remoting.PrioritySendDataCollection.Clear()
at System.Management.Automation.Remoting.Client.BaseClientTransportManager.CloseAsync()
at System.Management.Automation.Remoting.Client.WSManClientSessionTransportManager.CloseAsync()
at System.Management.Automation.Remoting.Client.BaseClientTransportManager.Finalize()
Abort trap: 6

The machine I am connecting to a Windows 2012 R2 server.
Can any one help me what is wrong with my setup? If this is not the preferred way can you please suggest some alternatives without installing anything special on window server.

Thanks & Regards

Hi Kalyan,

While I am not knowledgeable enough to tell you what the complexities are in getting this working, I can tell you that I saw this unofficially demo’d at Ignite yesterday. It’s something that they “just recently got working” (actual quote), and showed us as a teaser for things to come.

That being said the PowerShell gurus may come along and correct me if I’m wrong, but as far as I know, it is not something that works in the current release (I tried on my Macbook too), but seems to be on the near horizon.

It’s something I’m really looking forward to as well, because I don’t load modules when I don’t need to, on my local system even in Windows. I use remote PowerShell sessions for almost everything (AD, Exchange/EXO, Lync/S4B).

Thanks, and I hope this helps.