Pull Server not working

Hi, I have followed the instruction provided on https://technet.microsoft.com/en-au/library/dn249913.aspx to set up my pull server (Windows 2012 R2) and managed to the the Pull URL working. I can browse to https://[serverName]:8080/PSDSCPullServer.svc (on the server and node)

I am encountering issue with my node (Windows 7), the consistency schedule task is reporting:
This event indicates that failure happens when LCM is trying to get the configuration from pull server using download manager WebDownloadManager. ErrorId is 0x1. ErrorDetail is Failed to get the action from server https://[ServerName]:8080/PSDSCPullServer.svc/Action(ConfigurationId=‘a25ac337-399a-40a0-a74d-85891ccdb817’)/GetAction.

I get method no allow when I browse to the URL: https://[ServerName]:8080/PSDSCPullServer.svc/Action(ConfigurationId=‘a25ac337-399a-40a0-a74d-85891ccdb817’)/GetAction.

Both my Pull Server and Node are virtual machine and both are in the same domain.

Following is the LCM data for my node
PS C:\Windows\system32> Get-DscLocalConfigurationManager

AllowModuleOverwrite : False
CertificateID :
ConfigurationID : a25ac337-399a-40a0-a74d-85891ccdb817
ConfigurationMode : ApplyAndAutoCorrect
ConfigurationModeFrequencyMins : 30
Credential :
DownloadManagerCustomData : {MSFT_KeyValuePair (key = “ServerUrl”), MSFT_KeyValuePair (key = “AllowUnsecureConnection”)}
DownloadManagerName : WebDownloadManager
RebootNodeIfNeeded : False
RefreshFrequencyMins : 15
RefreshMode : Pull
PSComputerName :

It seems to me that my node does not have permission to access the GetAction method.

Hoping that someone can point me in the right direction.

Thanks,
Kah Wee

Solved!

I have incorrectly configured the Server to be secure (using HTTPS).

Cheers,
Kah Wee