PSSession, CredSSP - Request not supported Error

Hi All,

I am taking PSSESSION using CredSSP Authentication(Already configured CredSSP Client and Server),But getting the below Error :

Query :

$Session = New-PSSession -ComputerName “Test” -Authentication CredSSP -Credential $Cred

Error :

New-PSSession : [Test]Connecting to remote server[Test] failed with the following error message : The request is not supported.

CategoryInfo : OpenError : (System.Management…RemoteRunspace:RemoteRunspace) [New-PSSession].PSRemotingTransportException
FullyQualifiedErrorId : 50,PSSessionOpenFailed

Kindly help me to fix this!!

How are these machines related? Are they in a domain together? Not in a domain? Is the destination computer’s name exactly as listed in DNS and/or Active Directory?

Also, what PowerShell versions are you running on the client and server?

  1. Both Client and Server is running on PS Version 3.0
  2. Both machines are on the same domain.
  3. Destination computer tried with both IP and Host name, am getting the same error.

So, “Secrets of PowerShell Remoting” gets into some of these details, but…

Why not just allow the default Kerberos protocol to be used? However, note that you must connect using the target’s canonical AD name, in order for the mutual authentication to function. You can’t use IP address unless you take different steps, because the computer can’t be “found” in AD by IP.

But CredSSP has a number of requirements; see the “Second Hop” section in And, double check the CredSSP configuration - the target must be in “Server” mode, the origination must be in “Client” mode, and must specify the server as a trusted delegate.

Was this sorted for you? I am getting the same issue and not able to solve this. This used to work for me before. Suddenly this has broken and I am getting the error you got.


I ran into the same problem, and spent quite some time trying to find the answer. I was trying to create a CredSSP session from one Windows 10 machine to another. In the past this always worked perfectly for me, but now, a normal PSSession worked, but a CredSSP session threw the Request not supported error.

The clue came when I tried to RDP into the Windows 10 machine. In this case, an error dialog was shown indicating that it could be because of an update of ‘Oracle CredSSP encryption’ (free translation, I got it in Spanish). And a link to was provided.

The cause of the problem was connecting from Windows 10 1803 to Windows 10 1709. The solution was simple:

I didn’t have time for upgrading, so my quick and dirty choice was executing:

$RegKeyPath = 'Registry::HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\Policies\System\CredSSP\Parameters\'
$RegKeyName = 'AllowEncryptionOracle'
New-ItemProperty $RegKeyPath -Name $RegKeyName -Value '2' -PropertyType 'DWORD' -Force

Hope this helps

Maybe related to this

Yes. This was the issue.

Thank you Harmen and Jon. I would not have been able to figure this without your help. The update was the issue. With your help, I was able to sort it out :slight_smile: