Powershell ignores Windows region settings for List separator

While running on a Windows Server 2012 R2, I have the following problem with Powershell:

When I run a script to create a CSV (by running Excel com objects), it creates the CSV with “,” separators, therefore ignoring the Windows region settings for List separator, which is set as “;”.

I used the following code to get the current List separator:
“(Get-Culture).TextInfo.ListSeparator”
and the result is “,”

PS: This issue has been partially mentioned in my other post “Excel “Save as CSV” delimiter incorrect”, however I saw the need to create a separate post from it.

Hi everyone.

Finally resolved it. I just needed to restart my server for the Windows region settings to effect Powershell as well.