JEA is completely broken in RTM as well

I have entire project of automation within my company on hold due to JEA being broken in PS 5.0. I hoped new RTM version just released would offer some fixes but it’s still as broken as it is. Not only that but I also opened 4 different bugs on UserVoice and since there are no votes I assume it’s not that highly visible. Bugs are

  1. Lack of documentation (new cmdlets and new parameters are not having help file)
  2. PSsessionConfiguration file cmdlets are not producing well formed XML file
  3. Parameters withing PSSessionConfiguration file are not being read into WinRM at all
  4. Remoting from PS 5.0 to PS 2.0 is broken for return values

I’m really confused as to how this issues not only slipped through QA but also that nothing has been even acknowledged by PS team. But even bigger surprise to me that nobody else seems to notice it. How JEA being broken or no documentation or remoting to downlevel clients are low key items and people are not seeing it?
For such a great tool and such a good run until version PS 5.0 it’s real letdown for me personally. I’m supposed to be a driving motion within my company to automate stuff and teach counterparts to use Powershell and show how we can separate Roles/Responsibilites with JEA and show easy to use documentation is etc. But all I have right now is some product I used to expect from open source community instead.
I don’t know if this qualifies as “bitching” but I never expect Microsoft to let down on quality of their product this much. It’s not BETA any more and not only that but it second release of RTM and stuff is broken when it matters.

I wouldn’t expect anything other than the PSModulePath issue to be resolved in the republished WMF5. I haven’t seen any mentions about other changes/bugs.

I haven’t tried JEA myself yet, but I think it could be useful in my company. Sounds bad if it’s really buggy :frowning:

It would be nice if you could provide a link to 2. and 3. at uservoice.

Are you sure 4. is really something that could be considered a bug? On which OS are you running PS2? You can’t upgrade to a newer release?
Many things have change since PS2. I wouldn’t really expect PS5 to PS2 communication to work the same way as PS5 to PS5.

Bug 1.
Bug 2.
Bug 3.
Bug 4.

All of the bugs have been verified by other people before I submitted them.

This is not going to get any attention if the product group doesn’t perceive it’s having an impact. So go to each of those links and “vote up” the issue. Otherwise it will die on the vine.

I understand that part. What I don’t understand how those issues are not “high impact”? How exactly entire PowerShell community did not notice that all new documentation is missing? How nobody noticed that JEA is not working at all? How nobody noticed that you can not make valid session configuiration files for PSRemoting?
Is nobody using this features? How come I’m the only one doing it/complaining about it etc?

Actually, Bob, I’ve passed this along to make sure it’s seen. One response so far:

“As for documentation, it is still in progress, but we do have an experience guide that may prove useful: The help documentation is still being worked on. In the meantime, we have an experience guide that hopefully proves useful:

And, they’re going to be looking at each of the bugs.

GS, in as polite a way as possible, I’d like to ask you to dial it down just a bit - let’s try and keep it friendly. It isn’t the responsibility of the “entire PowerShell community” to notice that documentation is missing; we’ve noticed. The MVPs in particular have been very vocal about it - just not in places that you’ve seen. Keep in mind that a lot of discussion, in fact, happens in venues that are covered by nondisclosures, which means you’re not going to see them, but that doesn’t mean they’re not happening. I completely agree with you that bugs should be addressed - but I don’t want this becoming an attack on everyone in the community, please.

The team is aware of your feedback here, and I’ll pass along anything else I can.

I appreciate it.

Well I would not be as vocal if bugs I raised months ago at least were acknowledged on User Voice by product team. While bugs were still handled by Connect, even if bug would not be considered high priority at least I would know somebody noticed it and it’s being worked on.
But right now I see completely broken JEA which is listed as number 1 item of new features of PS 5.0 and bug reported to the responsible team and it’s not even acknowledged that it even exists or considered to be fixed.
I don’t care much about documentation really since there are alternatives exists like you mentinoed, but broken JEA is a serious issue which prevents me from following through automation portal I’ve been working for last year. If product team knows about those why latest RTM version lists this as a feature on release notes.

You’re welcome to be vocal; just try and keep it friendly. I do understand your frustration, but nobody on is responsible for it, or can materially help with it. We’re not the product team, we’re just a community of unpaid volunteers, trying to help. I do understand the desire to vent when you’re frustrated, and I’ve felt it myself sometimes, but venting here isn’t productive.

Actually this forums as far as I can go to reach product team since I know you and other MVPs actually have direct line to product team as you mentioned. Previously direct line was “Connect” but since it moved to UserVoice that line is gone. So I complaint about broken JEA here which is not correct venue as you said, I complained on offical MSDN forums which is not correct venue too, I raised bug on UserVoice with no results. Feature positioned as number 1 on list of new features in PS 5.0 is still broken in second “RTM” as well.
What do I do if all venues to raise/acknolwedge an issue are essentially broken one way or another?

If you feel you’ve run into bugs in WMF5 itself (vs JEA specifically), then you call Microsoft Product Support and open an incident. WMF5 is supported code, and if what you’ve got is a situation you can readily duplicate, then you’ll end up not being charged for it, and you’re much more likely to get prioritized as a fix.

Again, I don’t mind you calling attention to problems here, and I don’t mind trying to pass them along (which I’v done). All I’m asking is that you remember the people here aren’t responsible for the problem, so try and keep it friendly. I do appreciate it. Again - you are welcome to post problems here, but please don’t get accusatory about the community, and please keep the tone civil. Neither we nor the product team are the enemy.

Let’s leave it there, because this is getting off-track. I’ll leave this thread open in case there’s any additional response or feedback that I can share, or if anyone else wants to jump in to offer workarounds or corroboration.