Install won’t run

I am trying to install libre office quietly.
This successfully launches the installer:
Start-Process c:\temp\LibreOffice_7.2.7_Win_x64.msi
This doesn’t do anything:
Start-Process c:\temp\LibreOffice_7.2.7_Win_x64.msi -ArgumentList “/quiet”

Any help is greatly appreciated.

*.MSI file are not executables. You need to run msiexec.exe and provide the *.MSI file including some proper command line options to install a software package silently.

Regardless of that - When you post code, sample data, console output or error messages please format it as code using the preformatted text button ( </> ). Simply place your cursor on an empty line, click the button and paste your code.

Thanks in advance

How to format code in <---- Click :point_up_2:t4: :wink:

I have tried variations, including:
Start-Process msiexec.exe ‘/I c:\temp\LibreOffice_7.2.7_Win_x64.msi /quiet’

Start-Process msiexec.exe -ArgumentList ‘/I c:\temp\LibreOffice_7.2.7_Win_x64.msi /quiet’

Start-Process -FilePath “c:\temp\LibreOffice_7.2.7_Win_x64.msi” -ArgumentList “/msi EULA_ACCEPT=YES /qn”

cmd.exe MsiExec.exe /i “c:\temp\LibreOffice_7.2.7_Win_x64.msi” RebootYesNo=No /qn

I use this :

Start-Process "msiexec.exe" -ArgumentList "/i ""C:\temp\xxxx.msi"" NOHOOKS=1 /qn /norestart /log ""C:\temp\$Hostname-xxxx_install.log"" /quiet" -Wait -NoNewWindow

Can you please explain:

Thats just a needed parameter for the agent I was installing. You probably dont need that.

I run that command remotely via Invoke-Command, that’s why you see $Hostname in there for logging.

Please format your code as code.

This should do the trick …

Start-Process msiexec.exe -ArgumentList '/i c:\temp\LibreOffice_7.2.7_Win_x64.msi /qn'