Install remote AppFabric

Hi all,
I’m stuck into a problem and can’t come out. I have to install and configure AppFabric in remote computers. I have done the installation but I can’t proceed with the configuration.
Even if I try to execute a simple script like this:

Invoke-Command -ComputerName host -ScriptBlock{
   Initialize-ASMonitoringSqlDatabase  -Server DB –Database host

I get this error:

The specified database is not a valid Monitoring database or is not available.

    + CategoryInfo          : InvalidOperation: (Microsoft.Appli...lDatabaseCmdlet:InitializeASMonitoringSqlDatabaseCmdlet) [Initialize-ASMonitoringSqlDatabase],ApplicationServerManagementException
    + FullyQualifiedErrorId : MonitoringStoreMachineScopeNotSupported,Microsoft.ApplicationServer.Management.Commands.InitializeASMonitoringSqlDatabaseCmdlet
    + PSComputerName        : host

But if I run it from “host” everything work fine. I’ve think about a problem with a PSSession inside a PSSession, so I’ve tried to use Process-Class to run a new PowerShell but the final result is the same.
Some ideas?

Thanks all

You’re probably running into the “second hop” problem, as described in “Secrets of PowerShell Remoting.” Your credential is being delegated to the remote computer, but can’t be further passed along to the database by default. I don’t know if enabling the CredSSP authentication protocol would help across a database connection or not.