how to get the correct path

this is my script:

cmdkey /add:\zonghang_data /user:xxxxxxx /pass:xxxxx

$b = ‘\\zonghang_data’

$fin = Get-Childitem $b -Directory | Sort-Object LastAccessTime -Descending | select -First 1

Copy-Item $fin $dis -Recurse

but when i run

COPY-ITEM…i cant get the correct path about of the $fin!!

the $fin show the path is " c:\ " not the server directory!


Your code is fine but if $fin doesn’t show the correct path then it’s fairly easy to troubleshoot. Does the below line produces the correct folder?

Get-Childitem $b -Directory | Sort-Object LastAccessTime -Descending | select -First 1

yes…when i run the commend can get the correct folder!

then i put the object to the variable and use the Copy-ITEM commend , it cant get the correct folder!

the error msg: Copy-Item (Get-Childitem $b -Directory | Sort-Object LastAccessTime -Descending …

  •   + CategoryInfo          : ObjectNotFound: (C:\Windows\system32\20171210:String) [Copy-Item], ItemNotFoundEx

Actually the $fin path is “\\zonghang_data” not “c:\windows\system32” !

i dont know why !

Not entirely sure why, but this seems to work:

Copy-Item -Path $fin.PSPath -Destination $dis -Recurse

the command no problem…just didnt know why cant get the correct path.