Get-ADGroupMember : The operation returned because the timeout limit was exceede

ERROR :- Get-ADGroupMember : The operation returned because the timeout limit was exceeded.

Any idea to fix this? I’m trying to pull out a list of members who are part of a group.

If the number of returned objects is too large, the DC will cut off the operation and you’ll run into the timeout. This isn’t “broken,” it’s by design in those cases.

Off course the number of objects here are large, so please help me how do I get that information out to csv

Heyyy… we get it… this is a PTA for you… but no reason to get snippy. 8^}

This is a normal thing and not PS specific. This has been talked about a lot, for many years now. This is just how ADDS is when you make calls to it asking for a bunch of stuff. Thus this is really a ADDS 101 question, and not a PS one. Yet, we’ve all experienced this at one time or the other.

For example, unless you change things at the AD level, it’s only going to give you 1000 - 5000 objects, no matter how many above the 1-5K you have. You could split your AD calls into chunks and append to a CSV file.

To get more you have to change the setting, think differently. There are approaches to deal with this as discussed in many articles all over the web with some workarounds noted. Just searching with you post title, would return to you a very long list.

How to Exceed the Maximum Number of Allowed Objects from Get-ADGroupMember, Get-ADPrincipalGroupMembership, and Get-ADAccountAuthorizationGroup cmdlets
Solved: Powershell - Get-ADGroupMember : The size limit for this request was exceeded | Experts Exchange
powershell - Error: "Get-ADUser : The operation returned because the timeout limit was exceeded." - Stack Overflow
powershell - Active Directory operation timeout limit exceeded on one DC, but not on another - Stack Overflow

Have you tried a command like this?

$var = Get-ADGroup “Enter-Group-Name-Here” -Properties Member | Select -ExpandProperty Member