FTP Module Login Issue

Trying to use the FTP Module, to create a connection to an FTP server. and I pretty much the same error message each time I run command.

PS >Set-FTPConnection -Credentials $MyCred -Server

Set-FTPConnection : Exception calling “GetResponse” with “0” argument(s): “Unable to connect to the remote server”
At line:1 char:1

  • Set-FTPConnection -Credentials $MyCred -Server
  •   + CategoryInfo          : NotSpecified: (:) [Write-Error], WriteErrorException
      + FullyQualifiedErrorId : Microsoft.PowerShell.Commands.WriteErrorException,Set-FTPConnection

I’ve tried all manner of command parameters etc.

I didn’t know if there was a way to unpack the response so as to find out where the problem lies?
I don’t know if there is some way to view the credentials from Set-Credential to verify what is being passed for name and password?

I can access the FTP server without problems using Filezilla and PSFTP (the Putty FTP command line file).


You’d probably need to contact whoever wrote that module for support. However, “Unable to connect to the remote server” generally indicates a simple connection failure, not anything to do with authentication. When you connect to the server with filezilla, what URL do you use? is it just “” ?

Not even the ftp prefix… just

Yup…nothing too fancy. Here are the results form the FileZilla command window…

Connecting to…
Response: fzSftp started
Command: open “bas@” 22
Command: Pass: ********
Status: Connected to
Status: Retrieving directory listing…
Command: cd “/home/web/html/store/images/fy2014/Kids-Shop”
Response: New directory is: “/home/web/html/store/images/fy2014/Kids-Shop”
Command: ls