Exchange Powershell get-moverequest issue or am i missing something?


I’ve done some digging and I am not finding anyone else seeing this issue. I’ll setup the scenario.

Created a 2 node DAG. Added 10 mailboxes USR01_EX01 through USR05 & USR01_EX02 through USR05. Obviously when you create the users they sort of randomly get distributed between the available exchange mailbox databases. What I was attempting to do was move the EX01 users to the EX01 database/server and EX02 users to the EX02 database/server (this is for later testing purposes).

I run new-moverequest. It completes successfully. All of the get-* options show the database move. Show the previous database/new target one all correct. But if I run a get-mailbox the servername still shows the original servername.

Am I missing something or is the new-moverequest cmdlet not making all respective changes?

I realize this is more of an “Exchange” issue or at least an Exchange centric powershell cmdlet issue. However, the admins that actually use powershell as their primary means of administration are more likely to be viewing this forum and / or seen this issue.

I dont see a way to delete this. There is a bunch of funky stuff I am not understanding that I think has to do directly with the DAG. I am going to have to monkey around with it quite a bit more. Like: Why is get-mailboxdatabase now showing only server EX01 but if I do a get-mailboxdatabase | select admindisplayname,activationpreference I see the 2 databases with both servers listed with the preferences set properly… but only one server (when both are live) is being listed.

So yeah moderator just kill this one.

Yeah, this is definitely more Exchange than PowerShell. I personally don’t know the answer to this one, but we’ll see if anyone jumps in.

I think you are confusing a mailbox move from one database to another with the DAG member that is hosting the active mailbox database copy.

Let’s say you have 2 DB in a 2 node DAG. Let’s call the 2 DAG members EX1 dans EX2 dans the 2 db DB1 and DB2.

If you move a mailbox named “user1” from DB1 to DB2, it doesn’t change the DAG member that is hosting the ACTIVE copy of the DB.

So, if both DB1 and DB2 got their active copy on EX1, a mailbox move won’t change anything apart from the DB that contains the mailbox.

Also, the “servername” property obtained with the Get-Mailbox cmdlet is not a reliable info in a DAG environnement.

For example, to determine where mailbox “user1” is hosted in a DAG, you first get the DB name where that contains the mailbox, with something like this:

Get-Mailbox user1 | fl database

You’ll get the database name that contains mailbox “user1”. Let’s say it’s DB1.

Then, you determine which one of the DAG members is hosting the active copy of the database:

Get-MailboxDatabaseCopyStatus DB1 

This will list the each DAG member that is hosting a copy of the database DB1. The server that is hosting the active copy will have the “Mounted” status.

Hope this helps.