Enable-WSManCredSSP cannot be executed

Enable-WSManCredSSP : This command cannot be executed because the setting cannot be enabled.
At line:1 char:1

  • Enable-WSManCredSSP -Role client -DelegateComputer “Hyper-Vhostname”
  •   + CategoryInfo          : InvalidOperation: (System.String[]:String[]) [Enable-WSManCredSSP]
     , InvalidOperationException
      + FullyQualifiedErrorId : WsManError,Microsoft.WSMan.Management.EnableWSManCredSSPCommand
    
    

A bit of a long story. I lost connectivity to my Hyper-V host when as update to my only DC kept it from booting. I am using Timothy Gruber’s " REMOTELY MANAGING HYPER-V SERVER IN A WORKGROUP OR NON-DOMAIN"

I removed the Hyper-V host from the domain so it is just in a workgroup.

I get to the step Enable-WSManCredSSP but get the error above. I am trying to do this on a Widows 10 Pro machine that no longer has access to its DC. It takes some time for the error to appear so it appears to me that the Hyper-V host is not allowing it to happen.

Not sure what else I can do on the server:

PS C:\Users\Administrator> Enable-WSManCredSSP -Role server

CredSSP Authentication Configuration for WS-Management
CredSSP authentication allows the server to accept user credentials from a remote computer. If you enable
CredSSP authentication on the server, the server will have access to the user name and password of the client
computer if the client computer sends them. For more information, see the Enable-WSManCredSSP Help topic.
Do you want to enable CredSSP authentication?
[Y] Yes [N] No [S] Suspend [?] Help (default is “Y”): y

cfg : http://schemas.microsoft.com/wbem/wsman/1/config/service/auth
lang : en-US
Basic : true
Kerberos : true
Negotiate : true
Certificate : true
CredSSP : true
CbtHardeningLevel : Relaxed

Remote desktop to the Hyper-V server works fine.

Any idea on how to get Enable-WSManCredSSP to take on the client would be greatly appreciated.